aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am58
1 files changed, 3 insertions, 55 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index c0cd600..060098a 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,5 +1,5 @@
# This file is part of wyslij-po
-# Copyright (C) 2007, 2015-2017 Sergey Poznyakoff
+# Copyright (C) 2007-2021 Sergey Poznyakoff
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -19,10 +19,8 @@
info_TEXINFOS=wyslij-po.texi
wyslij_po_TEXINFOS=\
fdl.texi\
- rendition.texi\
values.texi
-
EXTRA_DIST = \
check-docs.sh\
gendocs_template\
@@ -32,51 +30,6 @@ EXTRA_DIST = \
clean-local:
rm -rf manual
-# Checking
-check-format:
- @if test -n "`cat $(info_TEXINFOS) $(wyslij_po_TEXINFOS) | tr -d -c '\t'`"; then \
- echo "Sources contain tabs; run make untabify"; \
- false; \
- fi
-
-check-options:
- @check-docs.sh options \
- '/argp_option options\[\] = /,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \
- 's/@opindex *\([^@,]*\).*/\1/p' \
- $(top_srcdir)/src/main.c -- \
- $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I$(srcdir) -E - \
- $(info_TEXINFOS)
-
-check-refs:
- @sed -e = $(info_TEXINFOS) $(wyslij_po_TEXINFOS) | \
- sed -n 'N;/@FIXME-.*ref/{s/\(^[0-9][0-9]*\).*@FIXME-.*ref{\([^}]*\)}.*/$(info_TEXINFOS):\1: \2/gp}' > $@-t; \
- if [ -s $@-t ]; then echo "Unresolved cross-references:"; cat $@-t;\
- fi
- rm -f $@-t
-
-check-fixmes:
- @sed -e = $(info_TEXINFOS) | \
- sed -n 'N;/@FIXME{/{s/\(^[0-9][0-9]*\).*@FIXME{\([^}]*\).*/$(info_TEXINFOS):\1: \2/gp}' > $@-t; \
- if [ -s $@-t ]; then echo "Unresolved FIXMEs:"; cat $@-t;\
- fi
- rm -f $@-t
-
-check-unrevised:
- @grep -Hn @UNREVISED $(info_TEXINFOS) > $@-t; \
- if [ -s $@-t ]; then \
- echo "Unrevised nodes:"; \
- cat $@-t; \
- rm $@-t; \
- false;\
- else \
- rm $@-t; \
- fi
-
-all-check-docs: check-format check-options check-refs check-fixmes check-unrevised
-
-check-docs:
- $(MAKE) -k all-check-docs
-
#
master-menu:
@@ -87,14 +40,9 @@ untabify:
final: untabify master-menu
-# The rendering level is one of PUBLISH, DISTRIB or PROOF.
-# Just call `make RENDITION=PROOF [target]' if you want PROOF rendition.
-
-MAKEINFOFLAGS=-D$(RENDITION)
-
GENDOCS=gendocs.sh
-TEXI2DVI=texi2dvi -t '@set $(RENDITION)' -E
+TEXI2DVI=texi2dvi --tidy -t '@set $(RENDITION)' -E
# Make sure you set TEXINPUTS.
# TEXINPUTS=/usr/share/texmf/pdftex/plain/misc/ is ok for most distributions
@@ -103,7 +51,7 @@ manual:
TEXINPUTS=$(srcdir):$(top_srcdir)/build-aux:$(TEXINPUTS) \
MAKEINFO="$(MAKEINFO) $(MAKEINFOFLAGS)" \
TEXI2DVI="$(TEXI2DVI) -t @finalout" \
- $(GENDOCS) --no-copy-images $(PACKAGE) '$(PACKAGE_NAME) manual'
+ $(SHELL) $(GENDOCS) --no-copy-images $(PACKAGE) '$(PACKAGE_NAME) manual'
manual.tar.bz2: manual
tar cfj manual.tar.bz2 manual

Return to:

Send suggestions and report system problems to the System administrator.