aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 385fe41..8791fca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,3 +16,12 @@
ACLOCAL_AMFLAGS = -I m4
SUBDIRS = src doc po
+
+gen_start_date = 2021-02-06
+
+.PHONY: ChangeLog
+ChangeLog:
+ $(AM_V_GEN)if test -d .git; then \
+ git log --pretty='format:%ct %an <%ae>%n%n%s%n%n%b%n' | \
+ awk -vsince=$(gen_start_date) -vappend=ChangeLog.svn -f $(top_srcdir)/git2chg.awk > ChangeLog; \
+ fi

Return to:

Send suggestions and report system problems to the System administrator.