aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac46
1 files changed, 4 insertions, 42 deletions
diff --git a/configure.ac b/configure.ac
index 604ccc4..48e1252 100644
--- a/configure.ac
+++ b/configure.ac
@@ -108,44 +108,5 @@ if test "$status_tcpwrap" = yes; then
fi
-
-# **********************
-# Preprocessor
-# **********************
-AC_ARG_WITH([preprocessor],
- AC_HELP_STRING([--without-preprocessor],
- [do not use external preprocessor]),
- [
-case "${withval}" in
-yes) use_ext_pp=yes ;;
-no) use_ext_pp=no ;;
-*) AC_MSG_ERROR(bad value ${withval} for --with-preprocessor) ;;
-esac],[use_ext_pp=yes])
-
-if test $use_ext_pp != no; then
- # Check for default preprocessor
- AC_ARG_VAR([DEFAULT_PREPROCESSOR],
- [Set default preprocessor name])
- if test -z "$DEFAULT_PREPROCESSOR" ; then
- DEFAULT_PREPROCESSOR="m4 -s"
- fi
-
- save_PATH=$PATH
- PREPROC_OPTIONS=`echo $DEFAULT_PREPROCESSOR | sed -n 's/[[^ ]][[^ ]]* //p'`
- case "$DEFAULT_PREPROCESSOR" in
- /*) PATH=`expr $DEFAULT_PREPROCESSOR : '\(.*\)/.*'`:$PATH
- DEFAULT_PREPROCESSOR=`expr $DEFAULT_PREPROCESSOR : '.*/\(.*\)'`;;
- esac
- AC_PATH_PROG(PPBIN, $DEFAULT_PREPROCESSOR)
- DEFAULT_PREPROCESSOR=$PPBIN
- if test -n "$DEFAULT_PREPROCESSOR"; then
- DEFAULT_PREPROCESSOR="$DEFAULT_PREPROCESSOR $PREPROC_OPTIONS"
- case $PPBIN in
- *m4) AC_SUBST(PP_SETUP_FILE,'pp-setup');; # Install default pp-setup
- esac
- fi
- PATH=$save_PATH
- DEFAULT_PREPROCESSOR="\\\"$DEFAULT_PREPROCESSOR\\\""
-else
- DEFAULT_PREPROCESSOR=NULL
-fi
+# Grecs subsystem
+GRECS_SETUP
@@ -174,3 +135,4 @@ AC_CONFIG_FILES([Makefile
gnu/Makefile
- gconf/Makefile
+ grecs/Makefile
+ grecs/src/Makefile
src/Makefile

Return to:

Send suggestions and report system problems to the System administrator.