aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 18 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d571518..cf0bf05 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
1# This file is part of Varnish-mib -*- autoconf -*- 1# This file is part of Varnish-mib -*- autoconf -*-
2# Copyright (C) 2014-2015 Sergey Poznyakoff 2# Copyright (C) 2014-2016 Sergey Poznyakoff
3# 3#
4# Varnish-mib is free software; you can redistribute it and/or modify 4# Varnish-mib is free software; you can redistribute it and/or modify
5# it under the terms of the GNU General Public License as published by 5# it under the terms of the GNU General Public License as published by
@@ -15,7 +15,7 @@
15# along with Varnish-mib. If not, see <http://www.gnu.org/licenses/>. 15# along with Varnish-mib. If not, see <http://www.gnu.org/licenses/>.
16 16
17AC_PREREQ(2.69) 17AC_PREREQ(2.69)
18AC_INIT([varnish-mib], 1.1, [gray@gnu.org]) 18AC_INIT([varnish-mib], 1.1.90, [gray@gnu.org])
19AC_CONFIG_SRCDIR(src/varnish_mib.mib2c) 19AC_CONFIG_SRCDIR(src/varnish_mib.mib2c)
20AM_CONFIG_HEADER(config.h) 20AM_CONFIG_HEADER(config.h)
21AC_CONFIG_AUX_DIR([build-aux]) 21AC_CONFIG_AUX_DIR([build-aux])
@@ -43,6 +43,22 @@ PKG_PROG_PKG_CONFIG
43# Checks for Varnish 43# Checks for Varnish
44PKG_CHECK_MODULES([VARNISHAPI], [varnishapi >= 4.0]) 44PKG_CHECK_MODULES([VARNISHAPI], [varnishapi >= 4.0])
45 45
46varnishapi_version() {
47 AC_DEFINE_UNQUOTED([VARNISHAPI_MAJOR],[$1],[Varnish API major version number])
48 AC_DEFINE_UNQUOTED([VARNISHAPI_MINOR],[$2],[Varnish API minor version number])
49 AC_DEFINE_UNQUOTED([VARNISHAPI_PATCH],[$3],[Varnish API patchlevel])
50}
51
52v=$($PKG_CONFIG --modversion varnishapi)
53if test -n "$v"; then
54 save_IFS=$IFS
55 IFS='.'
56 varnishapi_version $v
57 IFS=$save_IFS
58fi
59
60AC_CHECK_VSC_C_MAIN_MEMBERS
61
46# Check for Net-SNMP 62# Check for Net-SNMP
47AC_PATH_PROG([NET_SNMP_CONFIG], net-snmp-config, none, $PATH) 63AC_PATH_PROG([NET_SNMP_CONFIG], net-snmp-config, none, $PATH)
48if test "$NET_SNMP_CONFIG" = "none"; then 64if test "$NET_SNMP_CONFIG" = "none"; then

Return to:

Send suggestions and report system problems to the System administrator.