aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am34
1 files changed, 23 insertions, 11 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 52648c8..c0c3b8a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,31 +1,38 @@
-# This file is part of mailfrom filter.
+# This file is part of Pies.
# Copyright (C) 2008, 2009 Sergey Poznyakoff
#
-# This program is free software; you can redistribute it and/or modify
+# Pies is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 3, or (at your option)
# any later version.
#
-# This program is distributed in the hope that it will be useful,
+# Pies is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
+# along with Pies. If not, see <http://www.gnu.org/licenses/>. */
sbin_PROGRAMS = pies
pies_SOURCES = \
+ acl.c\
+ addrfmt.c\
depmap.c\
+ diag.c\
limits.c\
+ meta.c\
meta1gram.y\
meta1lex.l\
pies.c\
progman.c\
- socket.c
+ socket.c\
+ url.c\
+ userprivs.c
noinst_HEADERS = \
+ acl.h\
meta1gram.h\
meta1lex.h\
pies.h
@@ -38,20 +45,25 @@ DISTCLEANFILES = pies.rc
meta1lex.c: meta1gram.h
+incdir=$(pkgdatadir)/$(VERSION)/include
+inc_DATA = pp-setup
+
INCLUDES = \
- $(MAILUTILS_INCLUDES)\
- $(MU_COMMON_INCLUDES)\
-I$(top_srcdir)/lib\
- -I$(top_srcdir)/gnu
+ -I$(top_srcdir)/gnu\
+ -I$(top_srcdir)/grecs/src
LDADD = \
- ../lib/libmf.a\
+ ../lib/libpies.a\
+ ../grecs/src/libgrecs.a\
../gnu/libgnu.a\
- $(MAILUTILS_LIBS)\
$(MF_PROCTITLE_LIBS)
AM_CPPFLAGS=-DSYSCONFDIR=\"$(sysconfdir)\"\
- -DSTATEDIR=\"$(localstatedir)\"
+ -DSTATEDIR=\"$(localstatedir)\"\
+ -DDEFAULT_PREPROCESSOR="$(DEFAULT_PREPROCESSOR)"\
+ -DDEFAULT_VERSION_INCLUDE_DIR=\"$(incdir)\"\
+ -DDEFAULT_INCLUDE_DIR=\"$(pkgdatadir)/include\"
AM_YFLAGS=-dvt -pmeta1
AM_LFLAGS=-dvp -Pmeta1 -olex.yy.c

Return to:

Send suggestions and report system problems to the System administrator.