aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am57
1 files changed, 57 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..52648c8
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,57 @@
+# This file is part of mailfrom filter.
+# Copyright (C) 2008, 2009 Sergey Poznyakoff
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+sbin_PROGRAMS = pies
+
+pies_SOURCES = \
+ depmap.c\
+ limits.c\
+ meta1gram.y\
+ meta1lex.l\
+ pies.c\
+ progman.c\
+ socket.c
+
+noinst_HEADERS = \
+ meta1gram.h\
+ meta1lex.h\
+ pies.h
+
+EXTRA_DIST = pies.rcin
+noinst_DATA = pies.rc
+DISTCLEANFILES = pies.rc
+.rcin.rc:
+ $(AM_V_GEN)sed 's|SBINDIR|$(sbindir)|g' $< > $@
+
+meta1lex.c: meta1gram.h
+
+INCLUDES = \
+ $(MAILUTILS_INCLUDES)\
+ $(MU_COMMON_INCLUDES)\
+ -I$(top_srcdir)/lib\
+ -I$(top_srcdir)/gnu
+
+LDADD = \
+ ../lib/libmf.a\
+ ../gnu/libgnu.a\
+ $(MAILUTILS_LIBS)\
+ $(MF_PROCTITLE_LIBS)
+
+AM_CPPFLAGS=-DSYSCONFDIR=\"$(sysconfdir)\"\
+ -DSTATEDIR=\"$(localstatedir)\"
+
+AM_YFLAGS=-dvt -pmeta1
+AM_LFLAGS=-dvp -Pmeta1 -olex.yy.c

Return to:

Send suggestions and report system problems to the System administrator.