aboutsummaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am23
1 files changed, 18 insertions, 5 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 89812ca..a0d6614 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,5 +1,5 @@
# This file is part of GNU Pies.
-# Copyright (C) 2005, 2006, 2007, 2008, 2010, 2013 Sergey Poznyakoff
+# Copyright (C) 2005-2008, 2010, 2013, 2015 Sergey Poznyakoff
#
# GNU Pies is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -16,15 +16,28 @@
noinst_LIBRARIES=libpies.a
-noinst_HEADERS = libpies.h
+noinst_HEADERS = libpies.h grecsasrt.h
libpies_a_SOURCES=\
+ addrfmt.c\
arraymember.c\
+ grecsasrt.c\
+ mkfilename.c\
+ netrc.c\
parsetime.c\
proctitle.c\
- strtotok.c
+ pp.c\
+ split3.c\
+ strtotok.c\
+ url.c
-libpies_a_LIBADD=$(LIBOBJS)
+libpies_a_LIBADD=\
+ $(LIBOBJS)\
+ @GRECS_LDADD@
-AM_CPPFLAGS = -I$(top_srcdir)/gnu -I../gnu
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/gnu\
+ -I../gnu\
+ @GRECS_INCLUDES@\
+ -DDEFAULT_PREPROCESSOR="$(DEFAULT_PREPROCESSOR)"

Return to:

Send suggestions and report system problems to the System administrator.