aboutsummaryrefslogtreecommitdiff
path: root/ident/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ident/Makefile.am')
-rw-r--r--ident/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/ident/Makefile.am b/ident/Makefile.am
new file mode 100644
index 0000000..65ac145
--- /dev/null
+++ b/ident/Makefile.am
@@ -0,0 +1,35 @@
+# This file is part of GNU Pies.
+# Copyright (C) 2015 Sergey Poznyakoff
+#
+# GNU Pies is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Pies is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Pies. If not, see <http://www.gnu.org/licenses/>. */
+
+noinst_LIBRARIES = libident.a
+noinst_HEADERS = ident.h identity.h
+
+libident_a_SOURCES = \
+ provider.c\
+ ident.c\
+ system.c
+
+if PAM_COND
+ libident_a_SOURCES += pam.c
+endif
+
+AM_CPPFLAGS=\
+ -I$(top_srcdir)/lib\
+ -I.\
+ -I$(top_srcdir)/gnu\
+ -I$(top_builddir)/gnu\
+ @GRECS_INCLUDES@
+

Return to:

Send suggestions and report system problems to the System administrator.