aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am113
1 files changed, 16 insertions, 97 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index da7d47c..492a6ae 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -19,36 +19,25 @@ pies_TEXINFOS=\
fdl.texi\
inetd.texi\
macros.texi\
- rendition.texi\
usr-acl.texi
EXTRA_DIST = \
- check-docs.sh\
- fix-sentence-spacing.sed\
- gendocs_template\
- mastermenu.el\
- untabify.el
+ gendocs_template
clean-local:
@rm -rf manual
# Checking
-check-tabs:
- @if test -n "`cat $(info_TEXINFOS) $(pies_TEXINFOS) | tr -d -c '\t'`"; then \
- echo "Sources contain tabs; run make untabify"; \
- false; \
- fi
-check-sentence-spacing:
- @if cat $(info_TEXINFOS) $(pies_TEXINFOS) | sed 's/i\.e\. //g;s/e\.g\. //g;s/\.\.\. @//g' | grep -q '\. [@A-Z]'; then \
- echo >&2 "Sources contain single-space sentence separators"; \
- echo >&2 "Run make fix-sentence-spacing to fix"; \
- fi
+AM_MAKEINFOFLAGS = @IMPRIMATUR_MAKEINFOFLAGS@
+imprimatur_INPUT=$(info_TEXINFOS) $(pies_TEXINFOS)
+include ../imprimatur/imprimatur.mk
+CHECK_DOCS=$(top_srcdir)/@IMPRIMATUR_MODULE_DIR@/check-docs.sh
-check-format: check-tabs check-sentence-spacing
+check-format: imprimatur-format imprimatur-check-sentence-spacing
check-options:
- @check-docs.sh options \
+ @$(CHECK_DOCS) options \
'/argp_option options\[\] = /,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \
's/@opindex *\([^@,]*\).*/\1/p' \
$(top_srcdir)/src/pies.c -- \
@@ -56,7 +45,7 @@ check-options:
$(info_TEXINFOS)
check-config:
- @check-docs.sh 'configuration statements' \
+ @$(CHECK_DOCS) 'configuration statements' \
'/pies_keywords\[\] *= *{/,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \
's/@deffnx\{0,1\} {Config} *\([^@,]*\).*/\1/p' \
$(top_srcdir)/src/pies.c -- \
@@ -66,7 +55,7 @@ check-config:
check-sub-config:
@sed -n '/pies_keywords\[\] *= *{/,/^}/{p}' ../src/pies.c|tr '\n{' ' \n'|sed -n '/grecs_type_section/s/"\([^"]*\)".*grecs_type_section,[^,]*,[^,]*,[^,]*,[^,]*, *\(.*\) *}.*/\1 \2/p' | \
while read ident kw; do \
- check-docs.sh "$$ident configuration statements" \
+ $(CHECK_DOCS) "$$ident configuration statements" \
"/$$kw"'\[\] *= *{/,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \
"s/@deffnx\{0,1\} {Config: *$${ident}}"' *\([^@,]*\).*/\1/p' \
$(top_srcdir)/src/pies.c $(top_srcdir)/src/acl.c -- \
@@ -74,87 +63,16 @@ check-sub-config:
$(info_TEXINFOS); \
done
-check-refs:
- @for file in $(info_TEXINFOS) $(pies_TEXINFOS); \
- do \
- sed -e = $$file | \
- sed -n 'N;/@FIXME-.*ref/{s/\(^[0-9][0-9]*\).*@FIXME-.*ref{\([^}]*\)}.*/'$$file':\1: \2/gp}'; \
- done > $@-t; \
- if [ -s $@-t ]; then \
- echo "Unresolved cross-references:"; \
- cat $@-t;\
- rm $@-t; \
- else \
- rm -f $@-t; \
- fi
-
-check-fixmes:
- @for file in $(info_TEXINFOS) $(pies_TEXINFOS); \
- do \
- sed -e = $$file | \
- sed -n 'N;/@FIXME{/{s/\(^[0-9][0-9]*\).*@FIXME{\([^}]*\).*/'$$file':\1: \2/gp}'; \
- done > $@-t; \
- if [ -s $@-t ]; then \
- echo "Unresolved FIXMEs:"; \
- cat $@-t; \
- rm $@-t; \
- false; \
- else \
- rm -f $@-t; \
- fi
-
-check-writeme:
- @grep -Hn @WRITEME $(info_TEXINFOS) $(pies_TEXINFOS) > $@-t; \
- if [ -s $@-t ]; then \
- echo "Empty nodes:"; \
- cat $@-t; \
- rm $@-t; \
- false;\
- else \
- rm $@-t; \
- fi
-
-check-unrevised:
- @grep -Hn @UNREVISED $(info_TEXINFOS) $(pies_TEXINFOS) > $@-t; \
- if [ -s $@-t ]; then \
- echo "Unrevised nodes:"; \
- cat $@-t; \
- rm $@-t; \
- false;\
- else \
- rm $@-t; \
- fi
-
-all-check-docs: check-format check-options \
- check-config check-sub-config \
- check-refs check-fixmes check-writeme check-unrevised
+all-check-docs: imprimatur-basic-checks \
+ check-options check-config check-sub-config
check-docs:
@$(MAKE) -k all-check-docs
#
-
-master-menu:
- $(AM_V_GEN)emacs -batch -l mastermenu.el -f make-master-menu $(info_TEXINFOS)
-
-untabify:
- @emacs -batch -l untabify.el $(info_TEXINFOS) $(pies_TEXINFOS)
-
-fix-sentence-spacing:
- for file in $(info_TEXINFOS) $(wydawca_TEXINFOS); \
- do \
- if grep -q '\. [@A-Z]' $$file; then \
- mv $$file $${file}~; \
- sed -r -f fix-sentence-spacing.sed $${file}~ > $$file; \
- fi; \
- done
-
-final: untabify fix-sentence-spacing master-menu
-
-# The rendering level is one of PUBLISH, DISTRIB or PROOF.
-# Just call `make RENDITION=PROOF [target]' if you want PROOF rendition.
-
-MAKEINFOFLAGS=-D$(RENDITION)
+master-menu: imprimatur-master-menu
+untabify: imprimatur-untabify
+final: imprimatur-final
GENDOCS=gendocs.sh
@@ -166,8 +84,9 @@ TEXI2DVI=texi2dvi -t '@set $(RENDITION)' -E
manual:
rm -rf manual
TEXINPUTS=$(srcdir):$(top_srcdir)/build-aux:$(TEXINPUTS) \
- MAKEINFO="$(MAKEINFO) $(MAKEINFOFLAGS)" \
+ MAKEINFO="$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS)" \
TEXI2DVI="$(TEXI2DVI) -t @finalout" \
+ TEXI2HTML="texi2html $(AM_MAKEINFOFLAGS)" \
$(GENDOCS) --texi2html $(PACKAGE) '$(PACKAGE_NAME) manual'
manual.tar.bz2: manual

Return to:

Send suggestions and report system problems to the System administrator.