aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am24
1 files changed, 23 insertions, 1 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 97bff3f..ee522f2 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -59,12 +59,31 @@ check-options:
'/argp_option options\[\] = /,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \
's/@opindex *\([^@,]*\).*/\1/p' \
$(top_srcdir)/mfd/main.c -- \
$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \
$(info_TEXINFOS)
+check-config:
+ @check-docs.sh 'configuration statements' \
+ '/mf_cfg_param\[\] *= *{/,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \
+ 's/@deffn {Mailfromd Conf} *\([^@,]*\).*/\1/p' \
+ $(top_srcdir)/mfd/main.c -- \
+ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \
+ $(info_TEXINFOS)
+
+check-sub-config:
+ @list=`sed -n '/mf_cfg_param\[\] *= *{/,/^}/{s/[ \t]*{ *"\([^,"]*\)", *mu_cfg_section *,.*/\1/pg}' $(top_srcdir)/mfd/main.c`; \
+ for ident in $$list; do \
+ check-docs.sh "$$ident configuration statements" \
+ "/$${ident}_section_param"'\[\] *= *{/,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \
+ "s/@deffn {$${ident}}"' *\([^@,]*\).*/\1/p' \
+ $(top_srcdir)/mfd/main.c -- \
+ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \
+ $(info_TEXINFOS); \
+ done
+
check-builtins:
@check-docs.sh builtins \
'/MF_DEFUN/{s/[ \t]*MF_DEFUN *(\([a-zA-Z_][a-zA-Z0-9_]*\),.*/\1/p;s/[ \t]*MF_DEFUN_VARARGS\(_NO_PROM\)\? *(\([a-zA-Z_][a-zA-Z0-9_]*\),.*/\2/p;s/[ \t]*MF_DEFUN_CTYPE *(\([a-zA-Z_][a-zA-Z0-9_]*\))/\1/p}'\
's/@deftypefnx\{0,1\} {Built-in Function} *[^ ][^ ]* *\([^ ]*\).*/\1/p' \
$(top_srcdir)/mfd/bi_*.m4 -- \
$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \
@@ -134,13 +153,16 @@ check-unrevised:
rm $@-t; \
false;\
else \
rm $@-t; \
fi
-all-check-docs: check-format check-options check-pragmas check-builtins check-mflib check-exceptions check-refs check-fixmes check-writeme check-unrevised
+all-check-docs: check-format check-options check-pragmas \
+ check-config check-sub-config \
+ check-builtins check-mflib check-exceptions \
+ check-refs check-fixmes check-writeme check-unrevised
check-docs:
@$(MAKE) -k all-check-docs
#

Return to:

Send suggestions and report system problems to the System administrator.