aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am39
1 files changed, 15 insertions, 24 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index ee522f2..502c46e 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,34 +1,25 @@
-# This file is part of Mailfromd.
+# This file is part of Pies.
# Copyright (C) 2005, 2006, 2007, 2008, 2009 Sergey Poznyakoff
#
-# Mailfromd is free software; you can redistribute it and/or modify
+# Pies is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 3, or (at your option)
# any later version.
#
-# Mailfromd is distributed in the hope that it will be useful,
+# Pies is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with Mailfromd. If not, see <http://www.gnu.org/licenses/>.
+# along with Pies. If not, see <http://www.gnu.org/licenses/>.
-info_TEXINFOS=mailfromd.texi
-mailfromd_TEXINFOS=\
+info_TEXINFOS=pies.texi
+pies_TEXINFOS=\
fdl.texi\
- gacopyz.texi\
macros.texi\
- mtasim.texi\
pies.texi\
- pmult.texi\
- pragma-database.texi\
- pragma-option.texi\
- rendition.texi\
- smap.texi\
- strftime.texi\
- upgrade.texi\
- values.texi
+ rendition.texi
EXTRA_DIST = \
check-docs.sh\
@@ -41,7 +32,7 @@ clean-local:
# Checking
check-format:
- @if test -n "`cat $(info_TEXINFOS) $(mailfromd_TEXINFOS) | tr -d -c '\t'`"; then \
+ @if test -n "`cat $(info_TEXINFOS) $(pies_TEXINFOS) | tr -d -c '\t'`"; then \
echo "Sources contain tabs; run make untabify"; \
false; \
fi
@@ -65,7 +56,7 @@ check-options:
check-config:
@check-docs.sh 'configuration statements' \
'/mf_cfg_param\[\] *= *{/,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \
- 's/@deffn {Mailfromd Conf} *\([^@,]*\).*/\1/p' \
+ 's/@deffn {Pies Conf} *\([^@,]*\).*/\1/p' \
$(top_srcdir)/mfd/main.c -- \
$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \
$(info_TEXINFOS)
@@ -101,12 +92,12 @@ check-exceptions:
@check-docs.sh exceptions \
'/typedef enum mf_exception_code {/,/^};/s/[ \t]*mfe_\(.*\),.*/e_\1/p;/typedef enum mf_status_code {/,/^};/s/[ \t]*mf_\(.*\),.*/\1/p' \
's/@cindex \([^,][^,]*\), exception type/\1/p' \
- $(top_srcdir)/mfd/mailfromd.h -- \
+ $(top_srcdir)/mfd/pies.h -- \
$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \
$(info_TEXINFOS)
check-refs:
- @for file in $(info_TEXINFOS) $(mailfromd_TEXINFOS); \
+ @for file in $(info_TEXINFOS) $(pies_TEXINFOS); \
do \
sed -e = $$file | \
sed -n 'N;/@FIXME-.*ref/{s/\(^[0-9][0-9]*\).*@FIXME-.*ref{\([^}]*\)}.*/'$$file':\1: \2/gp}'; \
@@ -120,7 +111,7 @@ check-refs:
fi
check-fixmes:
- @for file in $(info_TEXINFOS) $(mailfromd_TEXINFOS); \
+ @for file in $(info_TEXINFOS) $(pies_TEXINFOS); \
do \
sed -e = $$file | \
sed -n 'N;/@FIXME{/{s/\(^[0-9][0-9]*\).*@FIXME{\([^}]*\).*/'$$file':\1: \2/gp}'; \
@@ -135,7 +126,7 @@ check-fixmes:
fi
check-writeme:
- @grep -Hn @WRITEME $(info_TEXINFOS) $(mailfromd_TEXINFOS) > $@-t; \
+ @grep -Hn @WRITEME $(info_TEXINFOS) $(pies_TEXINFOS) > $@-t; \
if [ -s $@-t ]; then \
echo "Empty nodes:"; \
cat $@-t; \
@@ -146,7 +137,7 @@ check-writeme:
fi
check-unrevised:
- @grep -Hn @UNREVISED $(info_TEXINFOS) $(mailfromd_TEXINFOS) > $@-t; \
+ @grep -Hn @UNREVISED $(info_TEXINFOS) $(pies_TEXINFOS) > $@-t; \
if [ -s $@-t ]; then \
echo "Unrevised nodes:"; \
cat $@-t; \
@@ -170,7 +161,7 @@ master-menu:
$(AM_V_GEN)emacs -batch -l mastermenu.el -f make-master-menu $(info_TEXINFOS)
untabify:
- @emacs -batch -l untabify.el $(info_TEXINFOS) $(mailfromd_TEXINFOS)
+ @emacs -batch -l untabify.el $(info_TEXINFOS) $(pies_TEXINFOS)
final: untabify master-menu

Return to:

Send suggestions and report system problems to the System administrator.