aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am39
1 files changed, 15 insertions, 24 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index ee522f2..502c46e 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,34 +1,25 @@
1# This file is part of Mailfromd. 1# This file is part of Pies.
2# Copyright (C) 2005, 2006, 2007, 2008, 2009 Sergey Poznyakoff 2# Copyright (C) 2005, 2006, 2007, 2008, 2009 Sergey Poznyakoff
3# 3#
4# Mailfromd is free software; you can redistribute it and/or modify 4# Pies is free software; you can redistribute it and/or modify
5# it under the terms of the GNU General Public License as published by 5# it under the terms of the GNU General Public License as published by
6# the Free Software Foundation; either version 3, or (at your option) 6# the Free Software Foundation; either version 3, or (at your option)
7# any later version. 7# any later version.
8# 8#
9# Mailfromd is distributed in the hope that it will be useful, 9# Pies is distributed in the hope that it will be useful,
10# but WITHOUT ANY WARRANTY; without even the implied warranty of 10# but WITHOUT ANY WARRANTY; without even the implied warranty of
11# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the 11# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
12# GNU General Public License for more details. 12# GNU General Public License for more details.
13# 13#
14# You should have received a copy of the GNU General Public License 14# You should have received a copy of the GNU General Public License
15# along with Mailfromd. If not, see <http://www.gnu.org/licenses/>. 15# along with Pies. If not, see <http://www.gnu.org/licenses/>.
16 16
17info_TEXINFOS=mailfromd.texi 17info_TEXINFOS=pies.texi
18mailfromd_TEXINFOS=\ 18pies_TEXINFOS=\
19 fdl.texi\ 19 fdl.texi\
20 gacopyz.texi\
21 macros.texi\ 20 macros.texi\
22 mtasim.texi\
23 pies.texi\ 21 pies.texi\
24 pmult.texi\ 22 rendition.texi
25 pragma-database.texi\
26 pragma-option.texi\
27 rendition.texi\
28 smap.texi\
29 strftime.texi\
30 upgrade.texi\
31 values.texi
32 23
33EXTRA_DIST = \ 24EXTRA_DIST = \
34 check-docs.sh\ 25 check-docs.sh\
@@ -41,7 +32,7 @@ clean-local:
41 32
42# Checking 33# Checking
43check-format: 34check-format:
44 @if test -n "`cat $(info_TEXINFOS) $(mailfromd_TEXINFOS) | tr -d -c '\t'`"; then \ 35 @if test -n "`cat $(info_TEXINFOS) $(pies_TEXINFOS) | tr -d -c '\t'`"; then \
45 echo "Sources contain tabs; run make untabify"; \ 36 echo "Sources contain tabs; run make untabify"; \
46 false; \ 37 false; \
47 fi 38 fi
@@ -65,7 +56,7 @@ check-options:
65check-config: 56check-config:
66 @check-docs.sh 'configuration statements' \ 57 @check-docs.sh 'configuration statements' \
67 '/mf_cfg_param\[\] *= *{/,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \ 58 '/mf_cfg_param\[\] *= *{/,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \
68 's/@deffn {Mailfromd Conf} *\([^@,]*\).*/\1/p' \ 59 's/@deffn {Pies Conf} *\([^@,]*\).*/\1/p' \
69 $(top_srcdir)/mfd/main.c -- \ 60 $(top_srcdir)/mfd/main.c -- \
70 $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \ 61 $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \
71 $(info_TEXINFOS) 62 $(info_TEXINFOS)
@@ -101,12 +92,12 @@ check-exceptions:
101 @check-docs.sh exceptions \ 92 @check-docs.sh exceptions \
102 '/typedef enum mf_exception_code {/,/^};/s/[ \t]*mfe_\(.*\),.*/e_\1/p;/typedef enum mf_status_code {/,/^};/s/[ \t]*mf_\(.*\),.*/\1/p' \ 93 '/typedef enum mf_exception_code {/,/^};/s/[ \t]*mfe_\(.*\),.*/e_\1/p;/typedef enum mf_status_code {/,/^};/s/[ \t]*mf_\(.*\),.*/\1/p' \
103 's/@cindex \([^,][^,]*\), exception type/\1/p' \ 94 's/@cindex \([^,][^,]*\), exception type/\1/p' \
104 $(top_srcdir)/mfd/mailfromd.h -- \ 95 $(top_srcdir)/mfd/pies.h -- \
105 $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \ 96 $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \
106 $(info_TEXINFOS) 97 $(info_TEXINFOS)
107 98
108check-refs: 99check-refs:
109 @for file in $(info_TEXINFOS) $(mailfromd_TEXINFOS); \ 100 @for file in $(info_TEXINFOS) $(pies_TEXINFOS); \
110 do \ 101 do \
111 sed -e = $$file | \ 102 sed -e = $$file | \
112 sed -n 'N;/@FIXME-.*ref/{s/\(^[0-9][0-9]*\).*@FIXME-.*ref{\([^}]*\)}.*/'$$file':\1: \2/gp}'; \ 103 sed -n 'N;/@FIXME-.*ref/{s/\(^[0-9][0-9]*\).*@FIXME-.*ref{\([^}]*\)}.*/'$$file':\1: \2/gp}'; \
@@ -120,7 +111,7 @@ check-refs:
120 fi 111 fi
121 112
122check-fixmes: 113check-fixmes:
123 @for file in $(info_TEXINFOS) $(mailfromd_TEXINFOS); \ 114 @for file in $(info_TEXINFOS) $(pies_TEXINFOS); \
124 do \ 115 do \
125 sed -e = $$file | \ 116 sed -e = $$file | \
126 sed -n 'N;/@FIXME{/{s/\(^[0-9][0-9]*\).*@FIXME{\([^}]*\).*/'$$file':\1: \2/gp}'; \ 117 sed -n 'N;/@FIXME{/{s/\(^[0-9][0-9]*\).*@FIXME{\([^}]*\).*/'$$file':\1: \2/gp}'; \
@@ -135,7 +126,7 @@ check-fixmes:
135 fi 126 fi
136 127
137check-writeme: 128check-writeme:
138 @grep -Hn @WRITEME $(info_TEXINFOS) $(mailfromd_TEXINFOS) > $@-t; \ 129 @grep -Hn @WRITEME $(info_TEXINFOS) $(pies_TEXINFOS) > $@-t; \
139 if [ -s $@-t ]; then \ 130 if [ -s $@-t ]; then \
140 echo "Empty nodes:"; \ 131 echo "Empty nodes:"; \
141 cat $@-t; \ 132 cat $@-t; \
@@ -146,7 +137,7 @@ check-writeme:
146 fi 137 fi
147 138
148check-unrevised: 139check-unrevised:
149 @grep -Hn @UNREVISED $(info_TEXINFOS) $(mailfromd_TEXINFOS) > $@-t; \ 140 @grep -Hn @UNREVISED $(info_TEXINFOS) $(pies_TEXINFOS) > $@-t; \
150 if [ -s $@-t ]; then \ 141 if [ -s $@-t ]; then \
151 echo "Unrevised nodes:"; \ 142 echo "Unrevised nodes:"; \
152 cat $@-t; \ 143 cat $@-t; \
@@ -170,7 +161,7 @@ master-menu:
170 $(AM_V_GEN)emacs -batch -l mastermenu.el -f make-master-menu $(info_TEXINFOS) 161 $(AM_V_GEN)emacs -batch -l mastermenu.el -f make-master-menu $(info_TEXINFOS)
171 162
172untabify: 163untabify:
173 @emacs -batch -l untabify.el $(info_TEXINFOS) $(mailfromd_TEXINFOS) 164 @emacs -batch -l untabify.el $(info_TEXINFOS) $(pies_TEXINFOS)
174 165
175final: untabify master-menu 166final: untabify master-menu
176 167

Return to:

Send suggestions and report system problems to the System administrator.