aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 10 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index c7b8f50..93ca3db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,12 +14,12 @@
# You should have received a copy of the GNU General Public License
# along with GNU Pies. If not, see <http://www.gnu.org/licenses/>.
-AC_PREREQ([2.63])
+AC_PREREQ([2.71])
AC_INIT([GNU Pies], [1.8.90], [bug-pies@gnu.org])
AC_CONFIG_SRCDIR([src/pies.h])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_HEADERS([config.h])
-AM_INIT_AUTOMAKE([1.15 gnits tar-ustar dist-bzip2 std-options silent-rules])
+AM_INIT_AUTOMAKE([1.16.5 gnits tar-ustar dist-bzip2 std-options silent-rules])
# Enable silent rules by default:
AM_SILENT_RULES([yes])
@@ -30,7 +30,7 @@ gl_EARLY
AC_PROG_MAKE_SET
AC_PROG_RANLIB
AC_PROG_YACC
-AC_PROG_LEX
+AC_PROG_LEX([noyywrap])
# Checks for libraries.
AC_CHECK_LIB(crypt, crypt)
@@ -47,7 +47,6 @@ AC_TYPE_UID_T
AC_TYPE_MODE_T
AC_TYPE_PID_T
AC_TYPE_SIZE_T
-AC_TYPE_SIGNAL
IU_CHECK_MEMBERS([struct msghdr.msg_control, struct msghdr.msg_accrights], , ,
[#include <sys/types.h>
@@ -76,6 +75,7 @@ gl_INIT
# Grecs
GRECS_SETUP([grecs],[tree-api tests git2chg getopt json sockaddr-list parser-meta1])
GRECS_HOST_PROJECT_INCLUDES='-I$(top_srcdir)/gnu -I$(top_builddir)/gnu'
+GRECS_HOST_PROJECT_LDADD='$(top_builddir)/gnu/libgnu.a'
# Test for setproctitle
MF_PROCTITLE
@@ -88,8 +88,7 @@ AM_GNU_GETTEXT_VERSION([0.19])
# PAM
status_pam=maybe
AC_ARG_ENABLE([pam],
- AC_HELP_STRING([--enable-pam],
- [enable PAM]),
+ AS_HELP_STRING([--enable-pam],[enable PAM]),
[
case "${enableval}" in
yes) status_pam=yes ;;
@@ -118,8 +117,7 @@ fi
# Build inetd
AC_ARG_ENABLE([inetd],
- AC_HELP_STRING([--enable-inetd],
- [build and install a replacement for SBINDIR/inetd]),
+ AS_HELP_STRING([--enable-inetd],[build and install a replacement for SBINDIR/inetd]),
[case $enableval in
yes) AC_SUBST([INETD], [inetd]);;
no) ;;
@@ -127,20 +125,16 @@ AC_ARG_ENABLE([inetd],
sysvinit_status=maybe
AC_ARG_ENABLE([sysvinit],
- AC_HELP_STRING([--enable-sysvinit],
- [compile the SystemV init support]),
+ AS_HELP_STRING([--enable-sysvinit],[compile the SystemV init support]),
[sysvinit_status=$enableval])
if test $sysvinit_status = "maybe"; then
- AC_TRY_COMPILE([#ifdef HAVE_UTMPX_H
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#ifdef HAVE_UTMPX_H
# include <utmpx.h>
#else
# include <utmp.h>
#endif
-],
-[int x = RUN_LVL;],
-[sysvinit_status=yes],
-[sysvinit_status=no])
+]], [[int x = RUN_LVL;]])],[sysvinit_status=yes],[sysvinit_status=no])
fi
test $sysvinit_status = "no"
@@ -153,6 +147,7 @@ AH_BOTTOM([
# ifndef ATTRIBUTE_NORETURN
# define ATTRIBUTE_NORETURN __attribute__ ((__noreturn__))
# endif
+void xalloc_die (void) ATTRIBUTE_NORETURN;
])
# #################################

Return to:

Send suggestions and report system problems to the System administrator.