aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index d1bb2a9..2b492da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,10 +97,10 @@ esac],[status_pam=maybe])
-AC_SUBST(PAM_LIBS,-lpam)
+AC_SUBST(PAM_LIBS)
if test "$status_pam" != "no"; then
- pam=$status_pam
AC_CHECK_HEADERS(security/pam_appl.h)
if test "$ac_cv_header_security_pam_appl_h" = "yes"; then
- AC_CHECK_LIB(dl, dlopen, [PAM_LIBS="$PAM_LIBS -ldl"])
+ AC_CHECK_LIB(dl, dlopen, [PAM_LIBS="-ldl"])
AC_CHECK_LIB(pam, pam_start,
- [status_pam=yes],
+ [status_pam=yes
+ PAM_LIBS="-lpam $PAM_LIBS"],
[status_pam=no], $PAM_LIBS)

Return to:

Send suggestions and report system problems to the System administrator.