aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 67e64f3..0f97a90 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,22 @@ ACLOCAL_AMFLAGS = -I m4 -I am -I grecs/am
SUBDIRS=gnu grecs lib src doc po
+dist-hook:
+ @PATCHLEV=`echo "$(PACKAGE_VERSION)" | \
+ sed -r "s/[0-9]+\.[0-9]+\.?//"`; \
+ if test $${PATCHLEV:-0} -lt 50; then \
+ if grep -q FIXME NEWS; then \
+ echo >&2 "NEWS file contains FIXMEs"; \
+ exit 1; \
+ fi; \
+ fi
+
+alpha:
+ $(MAKE) dist distdir=$(PACKAGE)-$(VERSION)-`date +"%Y%m%d"`
+
+alphacheck:
+ $(MAKE) distcheck distdir=$(PACKAGE)-$(VERSION)-`date +"%Y%m%d"`
+
# Define the following variables in order to use the ChangeLog rule below:
# prev_change_log [optional] Name of the previous ChangeLog file.
# gen_start_date [optional] Start ChangeLog from this date.
@@ -12,7 +28,7 @@ changelog_dir = .
.PHONY: ChangeLog
ChangeLog:
- if test -d .git; then \
+ @if test -d .git; then \
cmd=$(top_srcdir)/build-aux/gitlog-to-changelog; \
if test -n "$(gen_start_date)"; then \
cmd="$$cmd --since=\"$(gen_start_date)\""; \

Return to:

Send suggestions and report system problems to the System administrator.