aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am40
1 files changed, 11 insertions, 29 deletions
diff --git a/Makefile.am b/Makefile.am
index b3c49a2..de4bf81 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
# This file is part of GNU Pies.
-# Copyright (C) 2008, 2009, 2010 Sergey Poznyakoff
+# Copyright (C) 2008, 2009, 2010, 2011 Sergey Poznyakoff
#
# GNU Pies is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -34,37 +34,19 @@ alpha:
alphacheck:
$(MAKE) distcheck distdir=$(PACKAGE)-$(VERSION)-`date +"%Y%m%d"`
-# Define the following variables in order to use the ChangeLog rule below:
-# prev_change_log [optional] Name of the previous ChangeLog file.
-# gen_start_date [optional] Start ChangeLog from this date.
-# changelog_dir [mandatory] Directory where to create ChangeLog
+# Name of the previous ChangeLog file.
prev_change_log = ChangeLog.mfd
+# Start Git ChangeLog from this date.
gen_start_date = 2009-09-04
-changelog_dir = .
.PHONY: ChangeLog
ChangeLog:
- @if test -d .git; then \
- cmd=$(top_srcdir)/build-aux/gitlog-to-changelog; \
- if test -n "$(gen_start_date)"; then \
- cmd="$$cmd --since=\"$(gen_start_date)\""; \
- fi; \
- $$cmd --format='%s%n%n%b%n' | \
- sed '/<unknown>$$/d' | fmt -s > $(changelog_dir)/cl-t; \
- if test -n "$(prev_change_log)" && test -f "$(prev_change_log)"; \
- then \
- echo "" >> $(changelog_dir)/cl-t; \
- cat "$(prev_change_log)" | \
- sed '/^Local Variables:/,/^End:/d' >> $(changelog_dir)/cl-t; \
- fi; \
- echo "Local Variables:" >> $(changelog_dir)/cl-t; \
- echo "mode: change-log" >> $(changelog_dir)/cl-t; \
- echo "version-control: never" >> $(changelog_dir)/cl-t; \
- echo "buffer-read-only: t" >> $(changelog_dir)/cl-t; \
- echo "End:" >> $(changelog_dir)/cl-t; \
- echo "" >> $(changelog_dir)/cl-t; \
- sed -n '1,/^[^#]/s/^#//p' $(top_srcdir)/Makefile.am \
- >> $(changelog_dir)/cl-t; \
- rm -f $(changelog_dir)/ChangeLog; \
- mv $(changelog_dir)/cl-t $(changelog_dir)/ChangeLog; \
+ $(AM_V_GEN)if test -d .git; then \
+ git log --pretty='format:%ct %an <%ae>%n%n%s%n%n%b%n' | \
+ awk -f $(top_srcdir)/@GRECS_SUBDIR@/build-aux/git2chg.awk \
+ -vsince=\"$(gen_start_date)\" -vappend=\"$(prev_change_log)\" \
+ > ChangeLog.tmp; \
+ cmp ChangeLog ChangeLog.tmp > /dev/null 2>&1 || \
+ mv ChangeLog.tmp ChangeLog; \
+ rm -f ChangeLog.tmp; \
fi

Return to:

Send suggestions and report system problems to the System administrator.