aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2015-12-31 13:59:18 +0200
committerSergey Poznyakoff <gray@gnu.org.ua>2015-12-31 15:58:17 +0200
commit00e6c3c3ed06a258a02943fc49fa7c528025d747 (patch)
tree52530660be48fb5f4611bcc9393886bab8a70b72 /src/Makefile.am
parent7f204cc788de3e03a51087b1273deb5b59288cf2 (diff)
downloadpies-00e6c3c3ed06a258a02943fc49fa7c528025d747.tar.gz
pies-00e6c3c3ed06a258a02943fc49fa7c528025d747.tar.bz2
Command-line control interface.
* configure.ac (DEFAULT_CONTROL_URL): New subst variable. * grecs: Upgrade. * ident/pam.c (overwrite_and_free): Free ptr. * lib/Makefile.am: Add new sources. * src/addrfmt.c: Move to lib/addrfmt.c * lib/grecsasrt.c: New file. * lib/grecsasrt.h: New file. * lib/mkfilename.c: New file. * lib/netrc.c: New file. * lib/pp.c: New file. * lib/split3.c: New file. * src/url.c: Move from lib/url.c (pies_url_free_user, pies_url_free_passwd): New finctions. * lib/libpies.h (strsplit3): New proto. (pies_url_create, pies_url_destroy) (pies_url_get_arg, pies_url_copy) (pies_url_free_user, pies_url_free_passwd) (netrc_scan) (pp_add_option, pp_command_line, mkfilename) (sockaddr_to_str, sockaddr_to_astr): New protos * src/Makefile.am (bin_PROGRAMS): New program: piesctl (pies_SOURCES): Remove addrfmt.c and url.c. (noinst_HEADERS, BUILT_SOURCES): Add piesctl-cl.h * src/cmdline.opt: Use pp_* function family to build preprocessor command line. * src/ctl.c (http_header_hash): Use case-insensitive hashing. (ctlio_finalize_reply): Don't close connection after sending 401 response. (input): Remove ws and wsflags. All uses changed. (input_append): Use strsplit3 to parse the request line. * src/pies.c: Use pp_* function family to build preprocessor command line. Move assert_, mkfilename and _cb+_url functions into libpies. * src/pies.h (pies_sockaddr_storage): Move to libpies.h * src/piesctl.c: New file. * src/piesctl-cl.opt: New file.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am21
1 files changed, 15 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ab4546f..982bd12 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -15,10 +15,10 @@
# along with GNU Pies. If not, see <http://www.gnu.org/licenses/>. */
sbin_PROGRAMS = pies
+bin_PROGRAMS = piesctl
pies_SOURCES = \
acl.c\
- addrfmt.c\
ctl.c\
depmap.c\
diag.c\
@@ -33,7 +33,6 @@ pies_SOURCES = \
socket.c\
sysdep.c\
sysvinit.c\
- url.c\
utmp.c\
userprivs.c
@@ -43,11 +42,12 @@ noinst_HEADERS = \
meta1gram.h\
meta1lex.h\
pies.h\
- prog.h
+ prog.h\
+ piesctl-cl.h
meta1lex.c: meta1gram.h
-BUILT_SOURCES=cmdline.h
+BUILT_SOURCES=cmdline.h piesctl-cl.h
incdir=$(pkgdatadir)/$(VERSION)/include
inc_DATA = pp-setup
@@ -58,8 +58,9 @@ SUFFIXES=.opt .c .h
$(AM_V_GEN)m4 -s $(top_srcdir)/@GRECS_SUBDIR@/build-aux/getopt.m4 $< > $@
cmdline.h: cmdline.opt
+piesctl-cl.h: piesctl-cl.opt
-LDADD = \
+pies_LDADD = \
../ident/libident.a\
../lib/libpies.a\
@GRECS_LDADD@\
@@ -67,6 +68,13 @@ LDADD = \
$(MF_PROCTITLE_LIBS)\
@PAM_LIBS@
+piesctl_SOURCES = piesctl.c
+
+piesctl_LDADD = \
+ ../lib/libpies.a\
+ @GRECS_LDADD@\
+ ../gnu/libgnu.a
+
pkgstatedir=$(localstatedir)/pies
AM_CPPFLAGS=\
@@ -78,7 +86,8 @@ AM_CPPFLAGS=\
-DDEFAULT_PREPROCESSOR="$(DEFAULT_PREPROCESSOR)"\
-DDEFAULT_VERSION_INCLUDE_DIR=\"$(incdir)\"\
-DDEFAULT_INCLUDE_DIR=\"$(pkgdatadir)/include\"\
- -DDEFAULT_STATE_DIR=\"$(pkgstatedir)\"
+ -DDEFAULT_STATE_DIR=\"$(pkgstatedir)\"\
+ -DDEFAULT_CONTROL_URL=\"$(DEFAULT_CONTROL_URL)\"
AM_YFLAGS=-dvt -pmeta1
AM_LFLAGS=-dvp -Pmeta1 -olex.yy.c

Return to:

Send suggestions and report system problems to the System administrator.