aboutsummaryrefslogtreecommitdiff
path: root/pies/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2008-02-26 13:42:41 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2008-02-26 13:42:41 +0000
commitf439e7de17824c8c22c6cbbd80ac78eb6877f2cd (patch)
tree8ef85bbcc6da98f378ea2d99ed27271204db0772 /pies/Makefile.am
downloadpies-f439e7de17824c8c22c6cbbd80ac78eb6877f2cd.tar.gz
pies-f439e7de17824c8c22c6cbbd80ac78eb6877f2cd.tar.bz2
* pies/pies.c: New configuration statement "chdir".
* pies/progman.c (struct prog.v.p): New member `dir'. (register_prog): Initialize newp->v.p.dir; (prog_start): Change to the working directory, if required by config.
Diffstat (limited to 'pies/Makefile.am')
-rw-r--r--pies/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/pies/Makefile.am b/pies/Makefile.am
new file mode 100644
index 0000000..2c65baf
--- /dev/null
+++ b/pies/Makefile.am
@@ -0,0 +1,39 @@
+# This file is part of mailfrom filter.
+# Copyright (C) 2008 Sergey Poznyakoff
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+sbin_PROGRAMS = pies
+
+pies_SOURCES = depmap.c pies.c progman.c pies.h
+EXTRA_DIST = pies.rcin
+noinst_DATA = pies.rc
+DISTCLEANFILES = pies.rc
+.rcin.rc:
+ sed 's|SBINDIR|$(sbindir)|g' $< > $@
+
+INCLUDES = \
+ $(MAILUTILS_INCLUDES)\
+ $(MU_COMMON_INCLUDES)\
+ -I$(top_srcdir)/lib\
+ -I$(top_srcdir)/gnu\
+ -I../gnu
+
+LDADD = \
+ ../lib/libmf.a\
+ $(MAILUTILS_LIBS)\
+ ../gnu/libgnu.a
+
+AM_CPPFLAGS=-DSYSCONFDIR=\"$(sysconfdir)\"\
+ -DSTATEDIR=\"$(localstatedir)\"

Return to:

Send suggestions and report system problems to the System administrator.