aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2008-03-12 06:54:03 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2008-03-12 06:54:03 +0000
commitb1377ca43b2b866748e30913b24cae3a4d0c25c6 (patch)
tree8c0907a17b8795876406a4a73b712c5b5bbbf560 /doc/Makefile.am
parentc56ae1845ebbe64a9f73eb60f365a1f8f29a0100 (diff)
downloadpies-b1377ca43b2b866748e30913b24cae3a4d0c25c6.tar.gz
pies-b1377ca43b2b866748e30913b24cae3a4d0c25c6.tar.bz2
* doc/Makefile.am (check-refs, check-fixmes): Print correct
locations for multiple input files. Return a meaningful error code. * TODO: Update.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am35
1 files changed, 25 insertions, 10 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 17d5103..e6eedb9 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -83,18 +83,33 @@ check-exceptions:
$(info_TEXINFOS)
check-refs:
- @sed -e = $(info_TEXINFOS) $(mailfromd_TEXINFOS) | \
- sed -n 'N;/@FIXME-.*ref/{s/\(^[0-9][0-9]*\).*@FIXME-.*ref{\([^}]*\)}.*/$(info_TEXINFOS):\1: \2/gp}' > $@-t; \
- if [ -s $@-t ]; then echo "Unresolved cross-references:"; cat $@-t;\
- fi
- rm -f $@-t
+ @for file in $(info_TEXINFOS) $(mailfromd_TEXINFOS); \
+ do \
+ sed -e = $$file | \
+ sed -n 'N;/@FIXME-.*ref/{s/\(^[0-9][0-9]*\).*@FIXME-.*ref{\([^}]*\)}.*/'$$file':\1: \2/gp}'; \
+ done > $@-t; \
+ if [ -s $@-t ]; then \
+ echo "Unresolved cross-references:"; \
+ cat $@-t;\
+ rm $@-t; \
+ else \
+ rm -f $@-t; \
+ fi
check-fixmes:
- @sed -e = $(info_TEXINFOS) | \
- sed -n 'N;/@FIXME{/{s/\(^[0-9][0-9]*\).*@FIXME{\([^}]*\).*/$(info_TEXINFOS):\1: \2/gp}' > $@-t; \
- if [ -s $@-t ]; then echo "Unresolved FIXMEs:"; cat $@-t;\
- fi
- rm -f $@-t
+ @for file in $(info_TEXINFOS); \
+ do \
+ sed -e = $$file | \
+ sed -n 'N;/@FIXME{/{s/\(^[0-9][0-9]*\).*@FIXME{\([^}]*\).*/'$$file':\1: \2/gp}'; \
+ done > $@-t; \
+ if [ -s $@-t ]; then \
+ echo "Unresolved FIXMEs:"; \
+ cat $@-t; \
+ rm $@-t; \
+ false; \
+ else \
+ rm -f $@-t; \
+ fi
check-unrevised:
@grep -Hn @UNREVISED $(info_TEXINFOS) > $@-t; \

Return to:

Send suggestions and report system problems to the System administrator.