aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2009-09-15 10:40:29 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2009-09-15 10:40:54 +0300
commit989a5bbb74c3620abaa2191ce2c4f8d5968dbf0a (patch)
treec0b2324a523905c3c17201cc2468c9078976fc74 /configure.ac
parentdbad35177723e19147ab49b59a3728e00fe05875 (diff)
downloadpies-989a5bbb74c3620abaa2191ce2c4f8d5968dbf0a.tar.gz
pies-989a5bbb74c3620abaa2191ce2c4f8d5968dbf0a.tar.bz2
Branch off from the Mailfromd project into a separate repository.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac97
1 files changed, 97 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..192fc53
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,97 @@
+# This file is part of Pies. -*- autoconf -*-
+# Copyright (C) 2009 Sergey Poznyakoff
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.63])
+AC_INIT([pies], [1.0], [bug-mailfromd@gnu.org.ua])
+AC_CONFIG_SRCDIR([src/pies.h])
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([1.11 gnits tar-ustar dist-bzip2 std-options silent-rules])
+
+# Enable silent rules by default:
+AM_SILENT_RULES([yes])
+
+# Checks for programs.
+AC_PROG_CC
+gl_EARLY
+AC_PROG_MAKE_SET
+AC_PROG_RANLIB
+AC_PROG_YACC
+AC_PROG_LEX
+
+# Checks for libraries.
+
+# Checks for header files.
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h netinet/in.h stdint.h stdlib.h string.h sys/socket.h sys/time.h syslog.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_TYPE_UID_T
+AC_TYPE_MODE_T
+AC_TYPE_PID_T
+AC_TYPE_SIZE_T
+AC_TYPE_SIGNAL
+
+IU_CHECK_MEMBERS([struct msghdr.msg_control, struct msghdr.msg_accrights], , ,
+ [#include <sys/types.h>
+ #include <sys/socket.h>])
+
+# Checks for library functions.
+AC_FUNC_CHOWN
+AC_FUNC_FORK
+AC_CHECK_FUNCS([alarm dup2 gethostbyname isascii memmove memset select setenv socket strchr strcspn strtol strtoul sysconf getdtablesize])
+
+# Gnulib
+gl_INIT
+
+# **********************
+# Mailutils
+# **********************
+# FIXME
+AM_GNU_MAILUTILS(2.0, [mailer cfg argp], [:])
+
+# Test for setproctitle
+MF_PROCTITLE
+
+# Gettext.
+AM_ICONV
+AM_GNU_GETTEXT([external], [need-formatstring-macros])
+AM_GNU_GETTEXT_VERSION([0.17])
+
+# Doc hints.
+# Select a rendition level:
+# DISTRIB for stable releases (at most one dot in the version number)
+# and maintenance releases (two dots, patchlevel < 50)
+# PROOF for alpha releases.
+# PUBLISH can only be required manually when running make in doc/
+AC_SUBST(RENDITION)
+case `echo $VERSION|sed 's/[[^.]]//g'` in
+""|".") RENDITION=DISTRIB;;
+"..") if test `echo $VERSION | sed 's/.*\.//'` -lt 50; then
+ RENDITION=DISTRIB
+ else
+ RENDITION=PROOF
+ fi;;
+*) RENDITION=PROOF;;
+esac
+
+AC_CONFIG_FILES([Makefile
+ gnu/Makefile
+ lib/Makefile
+ src/Makefile
+ doc/Makefile
+ po/Makefile.in])
+AC_OUTPUT

Return to:

Send suggestions and report system problems to the System administrator.