aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2021-06-09 09:39:29 +0300
committerSergey Poznyakoff <gray@gnu.org>2021-06-09 10:08:21 +0300
commit94a9e0845542de0cb4d63b90ce04a26e30cb9748 (patch)
tree85fb63d6f4abb0835e6cf73341f40d58dc0ed551 /configure.ac
parent0b425c88a2686b76a533ef6c12cdc6a170a4a93e (diff)
downloadpies-94a9e0845542de0cb4d63b90ce04a26e30cb9748.tar.gz
pies-94a9e0845542de0cb4d63b90ce04a26e30cb9748.tar.bz2
Make preprocessor include path configurable.
The installation directory for pp-setup can be set at configure time using the --with-pp-setup option. To disable installing it, use --without-pp-setup. * NEWS: Raise patchlevel. * configure.ac (DEFAULT_INCLUDE_PATH): New variable. (PIES_INCDIR): New substitution variable. New option --with-pp-setup. * grecs: Pull 7427077b98. * src/Makefile.am (DEFAULT_VERSION_INCLUDE_DIR) (DEFAULT_INCLUDE_DIR): Replace by DEFAULT_INCLUDE_PATH. Install pp-setup conditionally. * src/cmdline.opt (pies_help_hook): Print include path. Fix arguments to grecs_find_include_file. * src/pies.c (config_init): Use DEFAULT_INCLUDE_PATH to initialize include path. * src/piesctl.c: Likewise.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 324e6e8..1c71f78 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,7 @@
# along with GNU Pies. If not, see <http://www.gnu.org/licenses/>.
AC_PREREQ([2.63])
-AC_INIT([GNU Pies], [1.5.93], [bug-pies@gnu.org.ua])
+AC_INIT([GNU Pies], [1.5.94], [bug-pies@gnu.org])
AC_CONFIG_SRCDIR([src/pies.h])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_HEADERS([config.h])
@@ -186,6 +186,22 @@ if test -d "/proc/self/fd" ; then
fi
# ##############################
+AC_SUBST([DEFAULT_INCLUDE_PATH],['$(pkgdatadir)/include:$(pkgdatadir)/$(VERSION)/include'])
+AC_ARG_VAR([DEFAULT_INCLUDE_PATH],
+ [Include path for configuration preprocessor])
+AC_SUBST([PIES_INCDIR],[${DEFAULT_INCLUDE_PATH##*:}])
+
+AC_ARG_WITH([pp-setup],
+ [AC_HELP_STRING([--with-pp-setup@<:@=PATH@:>@],
+ [Install pp-setup to this directory; use --without-pp-setup to not install it at all])],
+ [case $withval in
+ yes) ;;
+ no) PIES_INCDIR=;;
+ /*) PIES_INCDIR=$withval;;
+ *) AC_MSG_ERROR([bad value $withval for --with-pp-setup])
+ esac])
+
+AM_CONDITIONAL([PP_SETUP_COND], [test -n "$PIES_INCDIR"])
AC_SUBST([DEFAULT_PIES_CONTROL_URL],['unix:///tmp/$${PIES_INSTANCE}.ctl'])
AC_ARG_VAR([DEFAULT_PIES_CONTROL_URL],

Return to:

Send suggestions and report system problems to the System administrator.