aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2011-10-22 23:03:24 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2011-10-23 00:42:30 +0300
commit21ffba77b92f79a59c62728ede4ad7a4ecb5a0ee (patch)
treec3204285a3ba57d590d815c682f1113b6f48d834 /Makefile.am
parenteb8797c9a28f3f4e238bad89b56d331492df7828 (diff)
downloadpies-21ffba77b92f79a59c62728ede4ad7a4ecb5a0ee.tar.gz
pies-21ffba77b92f79a59c62728ede4ad7a4ecb5a0ee.tar.bz2
Switch to the latest Grecs.
* Makefile.am (ChangeLog): Use git2chg.awk to build it. * NEWS: Update. * bootstrap.conf (gnulib_modules): Grecs does not depend on gnulib any more. * configure.ac: Version 1.2.90. Define GRECS_HOST_PROJECT_INCLUDES, remove grecs Makefiles from AC_CONFIG_FILES: it is now done by GRECS_SETUP itself. * gnulib.modules (gitlog-to-changelog,argp): Remove. (configmake): New module. * grecs: Update to a52ab6c6. * lib/libpies.h: Remove redefinitions of _() and N_(). * src/Makefile.am: Update for the recent grecs. * src/acl.c: Rewrite using Grecs support for lists and symtabs. * src/acl.h: Likewise. * src/diag.c: Likewise. * src/inetd.c: Likewise. * src/meta1gram.y: Likewise. * src/meta1lex.h: Likewise. * src/meta1lex.l: Likewise. * src/pies.c: Likewise. * src/pies.h: Likewise. * src/progman.c: Likewise. * src/userprivs.c: Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am42
1 files changed, 12 insertions, 30 deletions
diff --git a/Makefile.am b/Makefile.am
index b3c49a2..de4bf81 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,8 @@
# This file is part of GNU Pies.
-# Copyright (C) 2008, 2009, 2010 Sergey Poznyakoff
+# Copyright (C) 2008, 2009, 2010, 2011 Sergey Poznyakoff
#
# GNU Pies is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 3, or (at your option)
# any later version.
#
@@ -31,40 +31,22 @@ dist-hook:
alpha:
$(MAKE) dist distdir=$(PACKAGE)-$(VERSION)-`date +"%Y%m%d"`
alphacheck:
$(MAKE) distcheck distdir=$(PACKAGE)-$(VERSION)-`date +"%Y%m%d"`
-# Define the following variables in order to use the ChangeLog rule below:
-# prev_change_log [optional] Name of the previous ChangeLog file.
-# gen_start_date [optional] Start ChangeLog from this date.
-# changelog_dir [mandatory] Directory where to create ChangeLog
+# Name of the previous ChangeLog file.
prev_change_log = ChangeLog.mfd
+# Start Git ChangeLog from this date.
gen_start_date = 2009-09-04
-changelog_dir = .
.PHONY: ChangeLog
-ChangeLog:
- @if test -d .git; then \
- cmd=$(top_srcdir)/build-aux/gitlog-to-changelog; \
- if test -n "$(gen_start_date)"; then \
- cmd="$$cmd --since=\"$(gen_start_date)\""; \
- fi; \
- $$cmd --format='%s%n%n%b%n' | \
- sed '/<unknown>$$/d' | fmt -s > $(changelog_dir)/cl-t; \
- if test -n "$(prev_change_log)" && test -f "$(prev_change_log)"; \
- then \
- echo "" >> $(changelog_dir)/cl-t; \
- cat "$(prev_change_log)" | \
- sed '/^Local Variables:/,/^End:/d' >> $(changelog_dir)/cl-t; \
- fi; \
- echo "Local Variables:" >> $(changelog_dir)/cl-t; \
- echo "mode: change-log" >> $(changelog_dir)/cl-t; \
- echo "version-control: never" >> $(changelog_dir)/cl-t; \
- echo "buffer-read-only: t" >> $(changelog_dir)/cl-t; \
- echo "End:" >> $(changelog_dir)/cl-t; \
- echo "" >> $(changelog_dir)/cl-t; \
- sed -n '1,/^[^#]/s/^#//p' $(top_srcdir)/Makefile.am \
- >> $(changelog_dir)/cl-t; \
- rm -f $(changelog_dir)/ChangeLog; \
- mv $(changelog_dir)/cl-t $(changelog_dir)/ChangeLog; \
+ChangeLog:
+ $(AM_V_GEN)if test -d .git; then \
+ git log --pretty='format:%ct %an <%ae>%n%n%s%n%n%b%n' | \
+ awk -f $(top_srcdir)/@GRECS_SUBDIR@/build-aux/git2chg.awk \
+ -vsince=\"$(gen_start_date)\" -vappend=\"$(prev_change_log)\" \
+ > ChangeLog.tmp; \
+ cmp ChangeLog ChangeLog.tmp > /dev/null 2>&1 || \
+ mv ChangeLog.tmp ChangeLog; \
+ rm -f ChangeLog.tmp; \
fi

Return to:

Send suggestions and report system problems to the System administrator.