aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL22
1 files changed, 19 insertions, 3 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 4129fa9..66990fe 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,3 +1,3 @@
# SNMP Sendmail Statistics Module -*- perl -*-
-# Copyright (C) 2015 Sergey Poznyakoff <gray@gnu.org>
+# Copyright (C) 2015, 2016 Sergey Poznyakoff <gray@gnu.org>
#
@@ -16,3 +16,5 @@
+use strict;
use ExtUtils::MakeMaker;
+use Module::Metadata;
@@ -22,3 +24,3 @@ WriteMakefile(
'ABSTRACT' => 'NetSNMP module for Sendmail statistics',
- 'LICENSE' => 'gpl_v3',
+ 'LICENSE' => 'gpl_3',
'FIRST_MAKEFILE' => 'Makefile',
@@ -30,3 +32,17 @@ WriteMakefile(
'NetSNMP::agent' => 0,
- 'NetSNMP::ASN' => 0 }
+ 'NetSNMP::ASN' => 0 },
+ MIN_PERL_VERSION => 5.10.0,
+ META_MERGE => {
+ 'meta-spec' => { version => 2 },
+ resources => {
+ repository => {
+ type => 'git',
+ url => 'git://git.gnu.org.ua/netsnmp-sendmail.git',
+ web => 'http://git.gnu.org.ua/cgit/netsnmp-sendmail.git/',
+ },
+ provides => Module::Metadata->provides(version => '2',
+ dir=>'$(INST_LIBDIR)')
+
+ }
+ }
);

Return to:

Send suggestions and report system problems to the System administrator.