aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL22
1 files changed, 19 insertions, 3 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 4129fa9..66990fe 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,5 +1,5 @@
# SNMP Sendmail Statistics Module -*- perl -*-
-# Copyright (C) 2015 Sergey Poznyakoff <gray@gnu.org>
+# Copyright (C) 2015, 2016 Sergey Poznyakoff <gray@gnu.org>
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -14,13 +14,15 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
+use strict;
use ExtUtils::MakeMaker;
+use Module::Metadata;
WriteMakefile(
'NAME' => 'NetSNMP::Sendmail',
'AUTHOR' => 'Sergey Poznyakoff <gray@gnu.org>',
'ABSTRACT' => 'NetSNMP module for Sendmail statistics',
- 'LICENSE' => 'gpl_v3',
+ 'LICENSE' => 'gpl_3',
'FIRST_MAKEFILE' => 'Makefile',
'VERSION_FROM' => 'sendmail.pl',
'PM' => {
@@ -28,7 +30,21 @@ WriteMakefile(
},
'PREREQ_PM' => { 'NetSNMP::OID' => 0,
'NetSNMP::agent' => 0,
- 'NetSNMP::ASN' => 0 }
+ 'NetSNMP::ASN' => 0 },
+ MIN_PERL_VERSION => 5.10.0,
+ META_MERGE => {
+ 'meta-spec' => { version => 2 },
+ resources => {
+ repository => {
+ type => 'git',
+ url => 'git://git.gnu.org.ua/netsnmp-sendmail.git',
+ web => 'http://git.gnu.org.ua/cgit/netsnmp-sendmail.git/',
+ },
+ provides => Module::Metadata->provides(version => '2',
+ dir=>'$(INST_LIBDIR)')
+
+ }
+ }
);
sub MY::postamble {

Return to:

Send suggestions and report system problems to the System administrator.