aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2021-06-17 16:46:13 +0300
committerSergey Poznyakoff <gray@gnu.org>2021-06-17 16:46:13 +0300
commit6fa210d16195ba4448648e171bb053d3b49fa095 (patch)
tree0700b62bfd5e5716ebf6e1313ec01b4cfb0c1d3b /configure.ac
parentc3a3d811d674b7fac0355253a5bd4c481e687a83 (diff)
downloadmockmta-master.tar.gz
mockmta-master.tar.bz2
Listen on arbitrary IP address/port. Use tcp-wrappers.HEADmaster
* README: Update. * configure.ac: New option --with-tcp-wrappers * mockmta.1: Document changes. * mockmta.c (port): Replace with portstr. (sockaddr_str, address_parse): New functions. (tcpwrap_access): New function. (mta_open): Take struct addrinfo * as argument. (thr_mta_listener): Verify connection using TCP wrappers and log the peer's IP address. (main): Likewise (for inetd mode). New option -s. Use syslog if it is given. (version): Report whether libwrap is used.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 28 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d7d5700..1d79f64 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,10 +13,13 @@ AC_CHECK_LIB(rt, clock_gettime)
AX_PTHREAD([],
[AC_MSG_ERROR([POSIX threads support is required, but not available])])
+#
+# GnuTLS
+#
gnutls_status=probe
AC_ARG_WITH([gnutls],
- [AC_HELP_STRING([--without-gnutls],
- [do not use the GNU TLS library])],
+ [AC_HELP_STRING([--with-gnutls],
+ [use the GNU TLS library (default)])],
[case "$withval" in
yes|no) gnutls_status=$withval;;
*) AC_MSG_ERROR([bad value for --with-gnutls])
@@ -34,5 +37,28 @@ fi
AC_SUBST([LIBGNUTLS_CFLAGS])
AC_SUBST([LIBGNUTLS_LIBS])
+#
+# TCP wrappers
+#
+# **********************
+# TCP wrappers
+# **********************
+AC_ARG_WITH(tcp-wrappers,
+ AC_HELP_STRING([--with-tcp-wrappers],
+ [compile with TCP wrappers support (default)]),
+ [status_tcpwrap=${withval}],
+ [status_tcpwrap=yes])
+
+if test "$status_tcpwrap" = yes; then
+ AC_CHECK_LIB(nsl, main)
+ AC_CHECK_LIB(wrap, main,, [status_tcpwrap=no])
+ if test "$status_tcpwrap" = yes; then
+ AC_CHECK_HEADERS(tcpd.h,,[status_tcpwrap=no])
+ fi
+fi
+if test "$status_tcpwrap" = yes; then
+ AC_DEFINE([WITH_LIBWRAP],1,[Defined if compiling with libwrap])
+fi
+
AC_CONFIG_FILES([Makefile])
AC_OUTPUT

Return to:

Send suggestions and report system problems to the System administrator.