summaryrefslogtreecommitdiff
path: root/mimeview/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mimeview/Makefile.am')
-rw-r--r--mimeview/Makefile.am20
1 files changed, 16 insertions, 4 deletions
diff --git a/mimeview/Makefile.am b/mimeview/Makefile.am
index 3f12908b3..f1d80babd 100644
--- a/mimeview/Makefile.am
+++ b/mimeview/Makefile.am
@@ -24,15 +24,27 @@ AM_CPPFLAGS = \
bin_PROGRAMS = mimeview
mimeview_SOURCES = \
mimeview.c \
- grammar.y \
- lexer.l \
+ grammar.c \
+ lexer.c \
mimeview.h\
grammar.h
-YLWRAP = $(MU_YLWRAP)
AM_YFLAGS=-vtd
AM_LFLAGS=-d
-EXTRA_DIST = gylwrap.conf
+
+grammar.c grammar.h: grammar.y
+lexer.c: lexer.l
+
+BUILT_SOURCES = \
+ grammar.c grammar.h \
+ lexer.c
+
+EXTRA_DIST = grammar.y lexer.l
+
+.l.c:
+ $(FLEX) -o $@ $(AM_LFLAGS) $<
+.y.c:
+ $(BISON) -o $@ $(AM_YFLAGS) $<
mimeview_LDADD = \
$(MU_APP_LIBRARIES)\

Return to:

Send suggestions and report system problems to the System administrator.