summaryrefslogtreecommitdiff
path: root/mailbox/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mailbox/Makefile.am')
-rw-r--r--mailbox/Makefile.am79
1 files changed, 71 insertions, 8 deletions
diff --git a/mailbox/Makefile.am b/mailbox/Makefile.am
index 8ddd09e3b..a4d42079e 100644
--- a/mailbox/Makefile.am
+++ b/mailbox/Makefile.am
@@ -32,13 +32,7 @@ bin_PROGRAMS = mailutils-config
localedir = $(datadir)/locale
DEFS = @DEFS@ -DLOCALEDIR=\"$(localedir)\"
-EXTRA_DIST = errors muerrno.cin strtok_r.c \
- strndup.c strnlen.c strchrnul.c argp-ba.c argp-eexst.c \
- argp-fmtstream.c argp-fs-xinl.c argp-help.c argp-parse.c argp-pv.c \
- argp-pvh.c argp-xinl.c getline.c getline.h parsedate.y pin.c regex.c \
- fgetpwent.c getopt.c getopt1.c
-
-noinst_HEADERS = argp-fmtstream.h argp-namefrob.h md5.h
+EXTRA_DIST = errors muerrno.cin parsedate.y pin.c fgetpwent.c
libmailbox_la_SOURCES = \
address.c \
@@ -68,7 +62,6 @@ mailcap.c \
mailer.c \
mapfile_stream.c \
mbx_default.c \
-md5.c \
message.c \
memory_stream.c \
mime.c \
@@ -98,6 +91,7 @@ url_smtp.c \
wicket.c
BUILT_SOURCES = parsedate.c muerrno.c
+MOSTLYCLEANFILES=
parsedate.c: $(srcdir)/parsedate.y
$(YLWRAP) "$(YACC) $(AM_YFLAGS)" $< \
@@ -122,3 +116,72 @@ mailutils_config_CFLAGS = -DCOMPILE_FLAGS="\"-I$(includedir)\"" \
-DGUILE_LIBS="\"$(GUILE_LIBS)\"" \
-DI18NLIBS="\"`test $(BUILD_INCLUDED_LIBINTL) = no && echo $(LIBINTL)`\""
+##:## EOF marker for gnulib-sync script. Please, do not remove ##:##
+## Do not change anything below this line ##
+
+BUILT_SOURCES += $(ALLOCA_H)
+EXTRA_DIST += alloca_.h
+
+# We need the following in order to create an <alloca.h> when the system
+# doesn't have one that works with the given compiler.
+all-local $(libmailbox_la_OBJECTS): $(ALLOCA_H)
+alloca.h: alloca_.h
+ cp $(srcdir)/alloca_.h $@-t
+ mv $@-t $@
+MOSTLYCLEANFILES += alloca.h alloca.h-t
+
+libmailbox_la_SOURCES += argp.h argp-ba.c argp-eexst.c \
+ argp-fmtstream.c argp-fmtstream.h argp-fs-xinl.c argp-help.c \
+ argp-namefrob.h argp-parse.c argp-pv.c argp-pvh.c argp-xinl.c
+
+libmailbox_la_SOURCES += getline.h
+EXTRA_DIST += getndelim2.h getndelim2.c
+
+libmailbox_la_SOURCES += regex.h
+
+libmailbox_la_SOURCES += strtok_r.h
+
+libmailbox_la_SOURCES += md5.h md5.c
+
+
+BUILT_SOURCES += $(GETOPT_H)
+EXTRA_DIST += getopt_.h getopt_int.h
+
+# We need the following in order to create an <getopt.h> when the system
+# doesn't have one that works with the given compiler.
+all-local $(libmailbox_la_OBJECTS): $(GETOPT_H)
+getopt.h: getopt_.h
+ cp $(srcdir)/getopt_.h $@-t
+ mv $@-t $@
+MOSTLYCLEANFILES += getopt.h getopt.h-t
+
+libmailbox_la_SOURCES += gettext.h
+
+
+libmailbox_la_SOURCES += minmax.h
+
+
+libmailbox_la_SOURCES += strcase.h
+
+libmailbox_la_SOURCES += strchrnul.h
+
+libmailbox_la_SOURCES += strndup.h
+
+
+EXTRA_DIST += sysexit_.h
+
+# We need the following in order to create a <sysexits.h> when the system
+# doesn't have one that works with the given compiler.
+all-local $(libmailbox_la_OBJECTS): $(SYSEXITS_H)
+sysexits.h: sysexit_.h
+ cp $(srcdir)/sysexit_.h sysexits.h-t
+ mv sysexits.h-t sysexits.h
+MOSTLYCLEANFILES += sysexits.h sysexits.h-t
+
+libmailbox_la_SOURCES += printf-args.h printf-parse.h vasnprintf.h
+
+libmailbox_la_SOURCES += vsnprintf.h
+
+libmailbox_la_SOURCES += xsize.h
+
+EXTRA_DIST += getline.c getline.c getndelim2.c getndelim2.c getopt.c getopt1.c mempcpy.c mempcpy.h mempcpy.c regex.c strcasecmp.c strncasecmp.c strchrnul.c strndup.c strnlen.c strtok_r.c vasnprintf.c printf-args.c printf-parse.c asnprintf.c vsnprintf.c

Return to:

Send suggestions and report system problems to the System administrator.