summaryrefslogtreecommitdiff
path: root/mail.remote/testsuite/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mail.remote/testsuite/Makefile.am')
-rw-r--r--mail.remote/testsuite/Makefile.am76
1 files changed, 76 insertions, 0 deletions
diff --git a/mail.remote/testsuite/Makefile.am b/mail.remote/testsuite/Makefile.am
new file mode 100644
index 000000000..59f4e87d5
--- /dev/null
+++ b/mail.remote/testsuite/Makefile.am
@@ -0,0 +1,76 @@
+# This file is part of GNU Mailutils
+# Copyright (C) 2000,2001,2002 Free Software Foundation
+# See file COPYING in the distribution root directory for copying conditions.
+
+AUTOMAKE_OPTIONS = dejagnu
+SMTP_DEJATOOL = mail.remote
+DEJATOOL = @RUN_SMTP_DEJATOOL@
+RUNTESTFLAGS =
+CLEANFILES = *.log
+test_dirs = lib mail.remote
+EXTRA_DIST = Data
+
+dist-hook:
+ here=`cd $(top_builddir)/$(subdir) && pwd`; \
+ srcdir=`cd $(srcdir) && pwd`; \
+ distdir=`cd $(distdir) && pwd`; \
+ for dir in $(test_dirs); \
+ do \
+ cd $$srcdir;\
+ mkdir $$distdir/$$dir;\
+ cd $$dir;\
+ for file in DISTFILES `cat DISTFILES`; do \
+ d=$$srcdir/$$dir; \
+ if test -d $$d/$$file; then \
+ cp -pr $$d/$$file $$distdir/$$dir/$$file; \
+ else \
+ test -f $$distdir/$$dir/$$file \
+ || cp -p $$d/$$file $$distdir/$$dir/$$file || exit; \
+ fi; \
+ done;\
+ done;\
+ cd $$here
+
+site.exp: Makefile remote.exp
+ @echo 'Making a new site.exp file...'
+ @test ! -f site.bak || rm -f site.bak
+ @echo '## these variables are automatically generated by make ##' > $@-t
+ @echo '# Do not edit here. If you wish to override these values' >> $@-t
+ @echo '# edit the last section' >> $@-t
+ @echo 'set tool $(DEJATOOL)' >> $@-t
+ @echo "set top_srcdir `cd $(top_srcdir); pwd`" >> $@-t
+ @echo "set top_builddir `cd $(top_builddir); pwd`" >> $@-t
+ @echo "set srcdir `cd $(srcdir); pwd`" >> $@-t
+ @echo 'set objdir' `pwd` >> $@-t
+ @echo 'set host_alias "$(host_alias)"' >> $@-t
+ @echo 'set host_triplet $(host_triplet)' >> $@-t
+ @echo 'set target_alias "$(target_alias)"' >> $@-t
+ @echo 'set target_triplet $(target_triplet)' >> $@-t
+ @echo 'set build_alias "$(build_alias)"' >> $@-t
+ @echo 'set build_triplet $(build_triplet)' >> $@-t
+ @echo '## All variables above are generated by configure. Do Not Edit ##' >> $@-t
+ @test ! -f site.exp || sed '1,/^## All variables above are.*##/ d' site.exp >> $@-t
+ @test ! -f site.exp || mv site.exp site.bak
+ @mv $@-t site.exp
+
+remote.exp:;
+ @echo 'Making a new remote.exp file...'
+ @test ! -f remote.bak || rm -f remote.bak
+ @echo '## These variables are used to set up for the remote testing.' >> $@-t
+ @echo '## Please, read file README in this directory for instructions' >> $@-t
+ @echo '## on how to use this file' >> $@-t
+ @echo "set host_board `hostname`" >> $@-t
+ @echo 'set board_info($$host_board,connect) rlogin' >> $@-t
+ @echo 'set board_info($$host_board,shell_prompt) "\\$$ "' >> $@-t
+ @echo "set board_info(\$$host_board,srcdir) `cd $(srcdir); pwd`" >> $@-t
+ @echo "set board_info(\$$host_board,objdir) `pwd`" >> $@-t
+ @echo "set board_info(\$$host_board,top_srcdir) `cd $(top_srcdir); pwd`" >> $@-t
+ @echo "set board_info(\$$host_board,top_builddir) `cd $(top_builddir); pwd`" >> $@-t
+ @test ! -f remote.exp || mv remote.exp remote.bak
+ @mv $@-t remote.exp
+
+
+DISTCLEANFILES=*.exp *.log *.sum
+
+distclean-local:
+ -rm -rf data

Return to:

Send suggestions and report system problems to the System administrator.