summaryrefslogtreecommitdiff
path: root/libsieve/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libsieve/Makefile.am')
-rw-r--r--libsieve/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/libsieve/Makefile.am b/libsieve/Makefile.am
new file mode 100644
index 000000000..4ce0bd5d6
--- /dev/null
+++ b/libsieve/Makefile.am
@@ -0,0 +1,36 @@
+# This file is part of GNU Mailutils
+# Copyright (C) 2000,2001,2002 Free Software Foundation
+# See file COPYING in the distribution root directory for copying conditions.
+
+INCLUDES = -I${top_srcdir}/include -I${top_srcdir}/lib
+YLWRAP = $(SHELL) $(top_srcdir)/scripts/ylwrap
+AM_YFLAGS = -dtv
+
+lib_LTLIBRARIES = libsieve.la
+
+noinst_PROGRAMS = sv
+
+libsieve_la_SOURCES = sieve-gram.c sieve-gram.h sieve-lex.c util.c
+sv_SOURCES = sv.c
+sv_LDADD = ./libsieve.la ../mailbox/libmailbox.la
+noinst_HEADERS = sieve.h
+
+BUILT_SOURCES= \
+ sieve-gram.c sieve-gram.h \
+ sieve-lex.c
+
+MAINTAINERCLEANFILES=$(BUILT_SOURCES)
+
+EXTRA_DIST = sieve.y sieve.l
+
+sieve-lex.c: $(srcdir)/sieve.l sieve-gram.h
+ $(YLWRAP) "$(LEX) $(AM_LEXFLAGS) $(LEXFLAGS)" \
+ $(srcdir)/sieve.l lex.yy.c sieve-lex.c \
+ -- -yy sieve_yy
+
+sieve-gram.c sieve-gram.h: $(srcdir)/sieve.y
+ $(YLWRAP) "$(YACC) $(AM_YFLAGS) $(YFLAGS)" $(srcdir)/sieve.y \
+ y.tab.c sieve-gram.c y.tab.h sieve-gram.h y.output y.output \
+ -- -yy sieve_yy
+
+

Return to:

Send suggestions and report system problems to the System administrator.