summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac116
1 files changed, 55 insertions, 61 deletions
diff --git a/configure.ac b/configure.ac
index 479360a99..f325a7735 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
dnl Configuration for GNU Mailutils -- a suite of utilities for electronic mail
dnl
-dnl Copyright (C) 1999-2021 Free Software Foundation, Inc.
+dnl Copyright (C) 1999-2024 Free Software Foundation, Inc.
dnl
dnl GNU Mailutils is free software; you can redistribute it and/or modify
dnl it under the terms of the GNU General Public License as published by
@@ -15,12 +15,12 @@ dnl
dnl You should have received a copy of the GNU General Public License along
dnl with GNU Mailutils. If not, see <http://www.gnu.org/licenses/>.
-AC_PREREQ(2.63)
-AC_INIT([GNU Mailutils], [3.12], [bug-mailutils@gnu.org], [mailutils],
+AC_PREREQ([2.71])
+AC_INIT([GNU Mailutils], [3.17], [bug-mailutils@gnu.org], [mailutils],
[http://mailutils.org])
AC_CONFIG_SRCDIR([libmailutils/mailbox/mailbox.c])
AC_CONFIG_AUX_DIR([build-aux])
-AM_INIT_AUTOMAKE([gnits 1.15 dist-bzip2 dist-xz std-options silent-rules])
+AM_INIT_AUTOMAKE([gnits 1.16.2 dist-bzip2 dist-xz std-options silent-rules])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_MACRO_DIR([m4])
@@ -31,7 +31,7 @@ dnl Autobuild stuff
AB_INIT
dnl Library versioning
-AC_SUBST(VI_CURRENT, 8)
+AC_SUBST(VI_CURRENT, 9)
AC_SUBST(VI_REVISION, 0)
AC_SUBST(VI_AGE, 0)
@@ -66,9 +66,6 @@ AC_SUBST(MU_LIB_COMMON_INCLUDES,'-I${top_builddir} -I${top_srcdir}/include -I${
AC_SUBST(MU_APP_COMMON_INCLUDES,'-I${srcdir} -I${top_srcdir}/include -I${top_srcdir}/lib -I${top_srcdir}/lib/gnu -I${top_builddir}/lib/gnu -I${top_builddir} -I${top_builddir}/include')
-# Use our replacement for the ylwrap tool
-AC_SUBST([MU_YLWRAP],'$(mu_aux_dir)/gylwrap --')
-
dnl Check for programs
AC_PROG_CC
AM_PROG_CC_C_O
@@ -151,7 +148,7 @@ MU_DEBUG_MODE
# For adventurous characters: enable experimental/unfinished/buggy stuff
AC_ARG_ENABLE([experimental],
- AC_HELP_STRING([--enable-experimental],
+ AS_HELP_STRING([--enable-experimental],
[build experimental and/or unfinished utilities]),
[mu_build_experimental="${enableval}"],
[mu_build_experimental=no])
@@ -163,7 +160,7 @@ AC_SUBST(MU_AUTHINCS)
dnl Check for arguments
AC_ARG_ENABLE([pam],
- AC_HELP_STRING([--disable-pam],
+ AS_HELP_STRING([--disable-pam],
[disable pam]),
[
case "${enableval}" in
@@ -173,7 +170,7 @@ case "${enableval}" in
esac],[testpam=yes])
AC_ARG_WITH(tcp-wrappers,
- AC_HELP_STRING([--with-tcp-wrappers],
+ AS_HELP_STRING([--with-tcp-wrappers],
[compile with TCP wrappers (libwrap) support]),
[status_tcpwrap=${withval}],
[status_tcpwrap=maybe])
@@ -214,7 +211,7 @@ fi
AC_SUBST([MU_TCPWRAP_LIBRARIES], "\${top_builddir}/lib/libmutcpwrap.a $TCPWRAP_LIBRARIES")
AC_ARG_ENABLE([pthread],
- AC_HELP_STRING([--disable-pthread],
+ AS_HELP_STRING([--disable-pthread],
[disable pthread]),
[
case "${enableval}" in
@@ -224,7 +221,7 @@ case "${enableval}" in
esac],[usepthread=yes])
AC_ARG_WITH([readline],
- AC_HELP_STRING([--without-readline],
+ AS_HELP_STRING([--without-readline],
[do not use readline]),
[
case "${withval}" in
@@ -237,7 +234,7 @@ AC_SUBST(SERV_AUTHLIBS)
AC_SUBST(SERV_AUTHINCS)
AC_ARG_WITH([gssapi],
- AC_HELP_STRING([--with-gssapi@<:@=PATH@:>@],
+ AS_HELP_STRING([--with-gssapi@<:@=PATH@:>@],
[use GSSAPI authentication]),
[status_gssapi=$withval],
[status_gssapi=probe])
@@ -270,7 +267,7 @@ AM_CONDITIONAL([MU_COND_GSASL],[test "$status_gsasl" = "yes"])
AC_SUBST(SITE_CRAM_MD5_PWD,"\$(sysconfdir)/cram-md5.pwd")
AC_ARG_WITH(cram-passwd,
- AC_HELP_STRING([--with-cram-passwd=FILE],
+ AS_HELP_STRING([--with-cram-passwd=FILE],
[keep passwords for CRAM-MD5 authentication method in FILE (default $SITE_CRAM_MD5_PWD)]),
[case "${withval}" in
/*) SITE_CRAM_MD5_PWD="${withval}";;
@@ -290,7 +287,7 @@ AM_CONDITIONAL([MU_COND_GNUTLS], [test "$status_gnutls" = yes])
AC_SUBST(SITE_MAIL_RC)
AC_ARG_WITH([mail-rc],
- AC_HELP_STRING([--with-mail-rc=FILE],
+ AS_HELP_STRING([--with-mail-rc=FILE],
[use FILE instead of $sysconfdir/mail.rc]),
[
case "${withval}" in
@@ -301,7 +298,7 @@ case "${withval}" in
MU_CONF_MAILDIR=
AC_ARG_WITH([mail-spool],
- AC_HELP_STRING([--with-mail-spool=PATH],
+ AS_HELP_STRING([--with-mail-spool=PATH],
[use PATH instead of /var/spool/mail]),
[
case "$withval" in
@@ -369,7 +366,7 @@ disable_dbm=no
all_dbm="GDBM BDB TC NDBM"
AC_ARG_WITH([dbm],
- AC_HELP_STRING([--with-dbm],
+ AS_HELP_STRING([--with-dbm],
[build DBM support (default yes)]),
[
case "${withval}" in
@@ -379,7 +376,7 @@ case "${withval}" in
esac])
AC_ARG_WITH([gdbm],
- AC_HELP_STRING([--with-gdbm],
+ AS_HELP_STRING([--with-gdbm],
[use GNU DBM]),
[
case "${withval}" in
@@ -389,7 +386,7 @@ case "${withval}" in
esac])
AC_ARG_WITH([berkeley-db],
- AC_HELP_STRING([--with-berkeley-db@<:@=LIBDB@:>@],
+ AS_HELP_STRING([--with-berkeley-db@<:@=LIBDB@:>@],
[use Berkeley DB]),
[
case "${withval}" in
@@ -399,7 +396,7 @@ case "${withval}" in
esac])
AC_ARG_WITH([ndbm],
- AC_HELP_STRING([--with-ndbm],
+ AS_HELP_STRING([--with-ndbm],
[use NDBM]),
[
case "${withval}" in
@@ -409,7 +406,7 @@ case "${withval}" in
esac])
AC_ARG_WITH([tokyocabinet],
- AC_HELP_STRING([--with-tokyocabinet],
+ AS_HELP_STRING([--with-tokyocabinet],
[use Tokyo Cabinet]),
[
case "${withval}" in
@@ -419,7 +416,7 @@ case "${withval}" in
esac])
AC_ARG_WITH([kyotocabinet],
- AC_HELP_STRING([--with-kyotocabinet],
+ AS_HELP_STRING([--with-kyotocabinet],
[use Kyoto Cabinet]),
[
case "${withval}" in
@@ -474,7 +471,6 @@ check_bdb() {
if test "$status_bdb" != no; then
AC_DEFINE_UNQUOTED(WITH_BDB,$ver)
DBMLIBS="-l$2 $DBMLIBS"
- MU_DB2_CURSOR
fi
fi
}
@@ -506,13 +502,9 @@ check_dbm_impl() {
DBMLIBS="$DBMLIBS -lgdbm"
status_dbm="$status_dbm,GDBM"]);;
- BDB) for version in 6 5 4 3 2
+ BDB) for version in 6 5 4
do
- case $version in
- 6|5|4|3) func=db_create;;
- 2) func=db_open;;
- esac
- check_bdb $version db $func
+ check_bdb $version db db_create
if test "$status_bdb" != no; then
status_dbm="$status_dbm,Berkeley DB v. $status_bdb"
break;
@@ -523,13 +515,9 @@ check_dbm_impl() {
name=`expr $1 : 'BDB=\(.*\)'`
case $name in
[[0-9]]*) check_slackware_bdb $name;;
- *) for version in 6 5 4 3 2
+ *) for version in 6 5 4
do
- case $version in
- 6|5|4|3) func=db_create;;
- 2) func=db_open;;
- esac
- check_bdb $version $name $func
+ check_bdb $version $name db_create
if test "$status_bdb" != no; then
status_dbm="$status_dbm,Berkeley DB v. $status_bdb"
break;
@@ -602,10 +590,13 @@ AM_CONDITIONAL([MU_COND_DBM], [test "$status_dbm" != no])
AC_MSG_CHECKING(for log facility)
log_facility="LOG_MAIL"
AC_ARG_WITH([log-facility],
- AC_HELP_STRING([--with-log-facility=facility],
- [enable logging to the given facility]),
- [AC_TRY_COMPILE([#include <syslog.h>], int lf = $withval,
- log_facility=$withval)])
+ [AS_HELP_STRING([--with-log-facility=facility],
+ [enable logging to the given facility])],
+ [AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM([[#include <syslog.h>
+ ]],
+ [[int lf = $withval]],
+ log_facility=$withval)])])
AC_DEFINE_UNQUOTED(LOG_FACILITY, $log_facility,
[Default syslog facility])
fstr=`echo "$log_facility" | tr A-Z a-z | sed 's/log_//'`
@@ -615,7 +606,6 @@ AC_DEFINE_UNQUOTED(LOG_FACILITY_STRING, "$fstr",
AC_MSG_RESULT($log_facility)
dnl Check for headers
-AC_HEADER_STDC
AC_HEADER_DIRENT
AC_CHECK_HEADERS(errno.h fcntl.h inttypes.h libgen.h limits.h\
malloc.h obstack.h paths.h shadow.h socket.h sys/socket.h stdarg.h stdio.h\
@@ -631,8 +621,6 @@ AC_TYPE_PID_T
AC_TYPE_SIZE_T
AC_TYPE_INTPTR_T
AC_CHECK_TYPE(ssize_t, , AC_DEFINE(ssize_t, int, [Define to int if <sys/types.h> does not define]))
-AC_TYPE_SIGNAL
-AC_DECL_SYS_SIGLIST
AC_STRUCT_TIMEZONE
AC_CHECK_TYPE(ino_t, , AC_DEFINE(ino_t, unsigned long, [Define to unsigned long if <sys/types.h> does not define]))
AC_CHECK_TYPE(dev_t, , AC_DEFINE(dev_t, unsigned long, [Define to unsigned long if <sys/types.h> does not define]))
@@ -714,7 +702,6 @@ AC_CHECK_FUNCS(mkstemp sigaction sysconf getdelim setreuid \
setresuid seteuid setlocale vfork _exit tcgetattr tcsetattr)
AC_FUNC_FSEEKO
-AC_FUNC_SETVBUF_REVERSED
AH_BOTTOM([
#if !defined (HAVE_FSEEKO)
@@ -753,7 +740,7 @@ AC_SUBST(FRIBIDI_LIBS)
use_fribidi=yes
AC_ARG_WITH([fribidi],
- AC_HELP_STRING([--without-fribidi],
+ AS_HELP_STRING([--without-fribidi],
[do not compile FriBidi support]),
[use_fribidi=$withval])
@@ -839,7 +826,7 @@ mysql_init() {
}
AC_ARG_WITH(mysql,
- AC_HELP_STRING([--with-mysql],
+ AS_HELP_STRING([--with-mysql],
[Configure to work with MySQL]),
[case $withval in
yes) add_sql_module "mysql"
@@ -863,7 +850,7 @@ postgres_init() {
}
AC_ARG_WITH(postgres,
- AC_HELP_STRING([--with-postgres],
+ AS_HELP_STRING([--with-postgres],
[Configure to work with Postgres]),
[case $withval in
yes) add_sql_module "postgres"
@@ -912,7 +899,7 @@ odbc_init() {
}
AC_ARG_WITH(odbc,
- AC_HELP_STRING([--with-odbc[={odbc|iodbc}]],
+ AS_HELP_STRING([--with-odbc[={odbc|iodbc}]],
[Configure to work with ODBC]),
[case $withval in
yes|odbc|ODBC|iodbc|iODBC|IODBC)
@@ -927,7 +914,7 @@ AC_ARG_WITH(odbc,
### General SQL support
AC_ARG_WITH(sql,
- AC_HELP_STRING([--with-sql=modlist],
+ AS_HELP_STRING([--with-sql=modlist],
[Configure to work with SQL]),
[for mod in `echo $withval | tr ':,' ' '`
do
@@ -973,7 +960,7 @@ fi
# LDAP support
AC_ARG_WITH(ldap,
- AC_HELP_STRING([--with-ldap],
+ AS_HELP_STRING([--with-ldap],
[Configure to work with OpenLDAP]),
[case $withval in
yes) status_ldap=maybe
@@ -1001,7 +988,7 @@ AM_CONDITIONAL([MU_COND_MAILBOX_QUOTA],[test "$status_dbm$status_mysql" != "nono
MU_ENABLE_SUPPORT(virtual-domains)
AC_SUBST(SITE_VIRTUAL_PWDDIR)
AC_ARG_WITH([virtual-pwddir],
- AC_HELP_STRING([--with-virtual-pwddir=DIR],
+ AS_HELP_STRING([--with-virtual-pwddir=DIR],
[use DIR instead of $sysconfdir/domain]),[
case "${withval}" in
/*) SITE_VIRTUAL_PWDDIR="${withval}";;
@@ -1088,9 +1075,6 @@ if test x"$usepthread" = x"yes"; then
fi
dnl Do we need extra libs for networking?
-AC_CHECK_FUNC(gethostbyname, [true],
- AC_CHECK_LIB(nsl, gethostbyaddr, LIBS="-lnsl $LIBS"))
-
AC_CHECK_FUNC(socket, [true],
AC_CHECK_LIB(socket, socket, LIBS="-lsocket $LIBS"))
@@ -1139,7 +1123,7 @@ AM_CONDITIONAL([MU_COND_READLINE], [test "$status_readline" = "yes"])
# Check for libunistring
AC_ARG_WITH([unistring],
- AC_HELP_STRING([--without-unistring],
+ AS_HELP_STRING([--without-unistring],
[do not use unistring]),
[
case "${withval}" in
@@ -1219,7 +1203,7 @@ AC_SUBST(lisp_LISP)
# Check for Python
AC_ARG_ENABLE([python],
- AC_HELP_STRING([--disable-python],
+ AS_HELP_STRING([--disable-python],
[do not build Python interface]),
[
case "${enableval}" in
@@ -1264,7 +1248,7 @@ PY_VERSION],
AC_SUBST([PYTHON_SITE_DIR])
AC_SUBST([PYTHON_EXEC_DIR])
AC_ARG_WITH([pythondir],
- AC_HELP_STRING([--with-pythondir=DIR],
+ AS_HELP_STRING([--with-pythondir=DIR],
[Specify the directory to install Python modules to]),
[case $withval in
/*) PYTHON_SITE_DIR="${withval}/mailutils"
@@ -1322,13 +1306,13 @@ dnl Configure particular utilities
dnl ***********************************************************************
AC_ARG_ENABLE([build-servers],
- AC_HELP_STRING([--enable-build-servers],
+ AS_HELP_STRING([--enable-build-servers],
[build servers]),
[mu_build_servers="${enableval}"],
[mu_build_servers=yes])
AC_ARG_ENABLE([build-clients],
- AC_HELP_STRING([--enable-build-clients],
+ AS_HELP_STRING([--enable-build-clients],
[build client utilities]),
[mu_build_clients="${enableval}"],
[mu_build_clients=yes])
@@ -1353,7 +1337,7 @@ MU_ENABLE_BUILD(frm,,,["$mu_build_clients" = yes],,[client_list])
MU_ENABLE_BUILD(mail,,,["$mu_build_clients" = yes],,[client_list])
AC_SUBST([MAILBINDIR],'${bindir}')
AC_ARG_WITH([mailbindir],
- [AC_HELP_STRING([--with-mailbindir=DIR],
+ [AS_HELP_STRING([--with-mailbindir=DIR],
[install mail to DIR [[BINDIR]]])],
[MAILBINDIR=$withval])
@@ -1370,7 +1354,7 @@ MU_ENABLE_BUILD(mh,,,["$mu_build_clients$mu_cv_enable_mh" = yesyes],,[client_lis
AC_SUBST(MH_BIN_DIR)
AC_ARG_WITH([mh-bindir],
- AC_HELP_STRING([--with-mh-bindir],
+ AS_HELP_STRING([--with-mh-bindir],
[Set the directory where to install the MH binaries. If it starts with '/' it is taken as an absolute path specification, otherwise ${prefix} is prepended to it. (Default: ${exec_prefix}/bin/mu-mh)]),
[case "${withval}" in
/*) MH_BIN_DIR=${withval};;
@@ -1392,6 +1376,7 @@ AC_CONFIG_TESTDIR(libtests)
AC_CONFIG_FILES([libtests/Makefile libtests/atlocal])
MU_CONFIG_TESTSUITE(libmailutils)
+MU_CONFIG_TESTSUITE(libmu_auth)
MU_CONFIG_TESTSUITE(frm)
MU_CONFIG_TESTSUITE(mda/lmtpd)
MU_CONFIG_TESTSUITE(mda/mda)
@@ -1426,6 +1411,14 @@ if test -z "$PERL"; then
fi
AC_SUBST([GITINFO],'$(PERL) $(mu_aux_dir)/gitinfo')
+# Maintainer variables
+AC_ARG_VAR([GNUPLOAD], [pathname of the gnupload script or compatible program])
+AC_ARG_WITH([gnupload],
+ [AS_HELP_STRING([--with-gnupload=PROGNAME],
+ [pathname of the gnupload script or compatible program])],
+ [GNUPLOAD=$withval],
+ [GNUPLOAD=gnupload])
+
AC_CONFIG_COMMANDS([status],[
cat <<EOF
@@ -1570,6 +1563,7 @@ AC_CONFIG_FILES([
libmailutils/mailcap/Makefile
libmailutils/mailer/Makefile
libmailutils/mime/Makefile
+ libmailutils/mimetypes/Makefile
libmailutils/msgset/Makefile
libmailutils/opt/Makefile
libmailutils/property/Makefile

Return to:

Send suggestions and report system problems to the System administrator.