summaryrefslogtreecommitdiff
path: root/testsuite/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2019-11-30 14:44:01 +0200
committerSergey Poznyakoff <gray@gnu.org>2019-11-30 16:07:09 +0200
commit55ac5cedee1baf716afc7882386d35c54b2f09a4 (patch)
treecedd080d9e94585c1255fc08c449e2cbc358e1ec /testsuite/Makefile.am
parentcfd3a6fe7f841d9992c521fbd8a6b6b1c048f413 (diff)
downloadmailutils-55ac5cedee1baf716afc7882386d35c54b2f09a4.tar.gz
mailutils-55ac5cedee1baf716afc7882386d35c54b2f09a4.tar.bz2
Improve makefile style consistency
. Uniformly use parentheses instead of curly braces in variable referencing . Prefer to use Make variables over substitution variables, for variables prefixed with MU_
Diffstat (limited to 'testsuite/Makefile.am')
-rw-r--r--testsuite/Makefile.am20
1 files changed, 10 insertions, 10 deletions
diff --git a/testsuite/Makefile.am b/testsuite/Makefile.am
index 4877bc27b..1bef60df4 100644
--- a/testsuite/Makefile.am
+++ b/testsuite/Makefile.am
@@ -33,7 +33,7 @@ EXTRA_DIST += \
## Non-installable programs
## -------------------------- ##
-AM_CPPFLAGS = @MU_LIB_COMMON_INCLUDES@
+AM_CPPFLAGS = $(MU_LIB_COMMON_INCLUDES)
noinst_PROGRAMS = \
bs\
cwdrepl\
@@ -46,20 +46,20 @@ noinst_PROGRAMS = \
ufms
LDADD = \
- ${MU_LIB_MAILBOX}\
- ${MU_LIB_MAILER}\
- ${MU_LIB_AUTH}\
- @MU_AUTHLIBS@\
- ${MU_LIB_MAILUTILS}\
+ $(MU_LIB_MAILBOX)\
+ $(MU_LIB_MAILER)\
+ $(MU_LIB_AUTH)\
+ $(MU_AUTHLIBS)\
+ $(MU_LIB_MAILUTILS)\
$(MU_COMMON_LIBRARIES)
smtpsend_LDADD = \
- ${MU_LIB_MAILER} \
- @MU_AUTHLIBS@\
- ${MU_LIB_MAILUTILS}\
+ $(MU_LIB_MAILER) \
+ $(MU_AUTHLIBS)\
+ $(MU_LIB_MAILUTILS)\
$(MU_COMMON_LIBRARIES)
-cwdrepl_LDADD = ${MU_LIB_MAILUTILS} $(MU_COMMON_LIBRARIES)
+cwdrepl_LDADD = $(MU_LIB_MAILUTILS) $(MU_COMMON_LIBRARIES)
## ------------ ##
## Test suite. ##

Return to:

Send suggestions and report system problems to the System administrator.