summaryrefslogtreecommitdiff
path: root/testsuite/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2010-09-17 00:48:07 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2010-09-17 00:48:07 +0300
commit20300ee417e027c1f2157a2e733982144ed35833 (patch)
tree886c18bd506c2f28d71fcd2ee90fe0be661f9746 /testsuite/Makefile.am
parent087627993732f3d00558d496e1baddf689112537 (diff)
downloadmailutils-20300ee417e027c1f2157a2e733982144ed35833.tar.gz
mailutils-20300ee417e027c1f2157a2e733982144ed35833.tar.bz2
Further improvement of the testsuite + some bugfixes.
That's the first commit since the merge six days ago that passes distcheck (with python, cxx, imap and nntp disabled, of course). * testsuite/folder/DISTFILES: Restore. It is needed for some of the remaining DejaGNU tests. * testsuite/spool/DISTFILES: Likewise. * testsuite/testsuite.at: New file. * testsuite/atlocal.in: New file. * libmailutils/tests/mbdel.at: Move to testsuite/. * libmailutils/tests/mbdel.c: Likewise. * libmailutils/tests/mime.at: Likewise. * libmailutils/tests/mimetest.c: Likewise. * Makefile.am (SUBDIRS): Place testsuite after libproto. * configure.ac (AM_INIT_AUTOMAKE): Remove dist-lzma. (AC_CONFIG_FILES): Add testsuite/atlocal. * libmailutils/base64.c (_base64_decoder) (_base64_encoder): Fix the use of uninitialized variables. * libmailutils/tests/.gitignore: Remove mbdel and mimetest. * libmailutils/tests/Makefile.am (noinst_PROGRAMS): Remove mbdel and mimetest. (LDADD): Leave only MU_LIB_MAILUTILS. (TESTSUITE_AT): Remove mbdel.at and mime.at * libmailutils/tests/atlocal.in (PATH): Bugfix. * libmailutils/tests/testsuite.at: Remove inclusion of mbdel.at and mime.at. * po/POTFILES.in: Replace mailbox/ with libmailutils/. * testsuite/.gitignore: Rewrite. * testsuite/Makefile.am: Rewrite. * testsuite/mbdel.at: Set +w on all copied mailboxes. * testsuite/mimetest.c (main): Open mailbox for reading only. * sieve/Makefile.am: Add examples/ to the distribution. * libproto/mbox/mbox.c (mbox_open): Create locker only if the mailbox is open for modification. All users updated to check for mailbox->locker!=NULL before using it.
Diffstat (limited to 'testsuite/Makefile.am')
-rw-r--r--testsuite/Makefile.am108
1 files changed, 88 insertions, 20 deletions
diff --git a/testsuite/Makefile.am b/testsuite/Makefile.am
index aef8c8832..bbe24936c 100644
--- a/testsuite/Makefile.am
+++ b/testsuite/Makefile.am
@@ -1,20 +1,88 @@
-## Process this file with GNU Automake to create Makefile.in
-
-## Copyright (C) 2002, 2007, 2010 Free Software Foundation, Inc.
-##
-## GNU Mailutils is free software; you can redistribute it and/or
-## modify it under the terms of the GNU General Public License as
-## published by the Free Software Foundation; either version 3, or (at
-## your option) any later version.
-##
-## This program is distributed in the hope that it will be useful, but
-## WITHOUT ANY WARRANTY; without even the implied warranty of
-## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-## General Public License for more details.
-##
-## You should have received a copy of the GNU General Public License
-## along with this program; if not, write to the Free Software
-## Foundation, Inc. 51 Franklin Street, Fifth Floor, Boston, MA
-## 02110-1301 USA
-
-EXTRA_DIST = lib etc spool folder maildir mh
+# This file is part of GNU Mailutils.
+# Copyright (C) 2010 Free Software Foundation, Inc.
+#
+# GNU Mailutils is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 3, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Mailutils. If not, see <http://www.gnu.org/licenses/>.
+
+EXTRA_DIST = $(TESTSUITE_AT) testsuite package.m4 lib etc spool folder maildir mh
+DISTCLEANFILES = atconfig $(check_SCRIPTS)
+MAINTAINERCLEANFILES = Makefile.in $(TESTSUITE)
+
+## ------------ ##
+## package.m4. ##
+## ------------ ##
+
+$(srcdir)/package.m4: $(top_srcdir)/configure.ac
+ $(AM_V_GEN){ \
+ echo '# Signature of the current package.'; \
+ echo 'm4_define([AT_PACKAGE_NAME], [@PACKAGE_NAME@])'; \
+ echo 'm4_define([AT_PACKAGE_TARNAME], [@PACKAGE_TARNAME@])'; \
+ echo 'm4_define([AT_PACKAGE_VERSION], [@PACKAGE_VERSION@])'; \
+ echo 'm4_define([AT_PACKAGE_STRING], [@PACKAGE_STRING@])'; \
+ echo 'm4_define([AT_PACKAGE_BUGREPORT], [@PACKAGE_BUGREPORT@])'; \
+ } >$(srcdir)/package.m4
+
+#
+
+## -------------------------- ##
+## Non-installable programs
+## -------------------------- ##
+
+INCLUDES = @MU_LIB_COMMON_INCLUDES@
+noinst_PROGRAMS = \
+ mbdel\
+ mimetest
+
+LDADD = \
+ ${MU_LIB_MBOX}\
+ ${MU_LIB_IMAP}\
+ ${MU_LIB_POP}\
+ ${MU_LIB_NNTP}\
+ ${MU_LIB_MH}\
+ ${MU_LIB_MAILDIR}\
+ ${MU_LIB_MAILER}\
+ ${MU_LIB_AUTH}\
+ @MU_AUTHLIBS@\
+ ${MU_LIB_MAILUTILS}
+
+## ------------ ##
+## Test suite. ##
+## ------------ ##
+
+TESTSUITE_AT = \
+ mbdel.at\
+ mime.at\
+ testsuite.at
+
+TESTSUITE = $(srcdir)/testsuite
+M4=m4
+
+AUTOTEST = $(AUTOM4TE) --language=autotest
+$(TESTSUITE): package.m4 $(TESTSUITE_AT)
+ $(AM_V_GEN)$(AUTOTEST) -I $(srcdir) -I $(top_srcdir)/testsuite testsuite.at -o $@.tmp
+ $(AM_V_at)mv $@.tmp $@
+
+atconfig: $(top_builddir)/config.status
+ cd $(top_builddir) && ./config.status tests/$@
+
+clean-local:
+ @test ! -f $(TESTSUITE) || $(SHELL) $(TESTSUITE) --clean
+
+check-local: atconfig atlocal $(TESTSUITE)
+ @$(SHELL) $(TESTSUITE)
+
+# Run the test suite on the *installed* tree.
+#installcheck-local:
+# $(SHELL) $(TESTSUITE) AUTOTEST_PATH=$(exec_prefix)/bin
+
+

Return to:

Send suggestions and report system problems to the System administrator.