summaryrefslogtreecommitdiff
path: root/testsuite/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2010-09-16 12:53:52 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2010-09-16 12:53:52 +0300
commit087627993732f3d00558d496e1baddf689112537 (patch)
tree396d4590dabed8b64f7276004e11fa5f1d8e588b /testsuite/Makefile.am
parentd74b5f53991d83e0a3c34e8d898cce942981ccb8 (diff)
downloadmailutils-087627993732f3d00558d496e1baddf689112537.tar.gz
mailutils-087627993732f3d00558d496e1baddf689112537.tar.bz2
Test mailbox deletion.
* libmailutils/tests/mbdel.at: New testcase. * libmailutils/tests/Makefile.am (TESTSUITE_AT): Add mbdel.at. * libmailutils/tests/testsuite.at: Include mbdel.at. * libproto/mbox/mbox.c (mbox_remove): Fix return code. * testsuite/maildir/mbox1: New test mailbox. * testsuite/mh/mbox1: New test mailbox. * testsuite/etc/DISTFILES: Remove. * testsuite/folder/DISTFILES: Remove. * testsuite/lib/DISTFILES: Remove. * testsuite/Makefile.am: Use EXTRA_DIST to distribute subdirs.
Diffstat (limited to 'testsuite/Makefile.am')
-rw-r--r--testsuite/Makefile.am28
1 files changed, 1 insertions, 27 deletions
diff --git a/testsuite/Makefile.am b/testsuite/Makefile.am
index 5182ae078..aef8c8832 100644
--- a/testsuite/Makefile.am
+++ b/testsuite/Makefile.am
@@ -17,30 +17,4 @@
## Foundation, Inc. 51 Franklin Street, Fifth Floor, Boston, MA
## 02110-1301 USA
-test_dirs = lib etc spool folder
-
-dist-hook:
- @here=`cd $(top_builddir)/$(subdir) && pwd`; \
- srcdir=`cd $(srcdir) && pwd`; \
- distdir=`cd $(distdir) && pwd`; \
- for dir in $(test_dirs); \
- do \
- cd $$srcdir;\
- mkdir $$distdir/$$dir;\
- cd $$dir;\
- for file in DISTFILES `cat DISTFILES`; do \
- d=$$srcdir/$$dir; \
- if test -d $$d/$$file; then \
- cp -pr $$d/$$file $$distdir/$$dir/$$file; \
- else \
- test -f $$distdir/$$dir/$$file \
- || cp -p $$d/$$file $$distdir/$$dir/$$file || exit; \
- fi; \
- done;\
- done;\
- cd $$here
-
-DISTCLEANFILES=*.exp *.log *.sum
-
-distclean-local:
- -rm -rf data
+EXTRA_DIST = lib etc spool folder maildir mh

Return to:

Send suggestions and report system problems to the System administrator.