summaryrefslogtreecommitdiff
path: root/sieve/Makefile.am
diff options
context:
space:
mode:
authorAlain Magloire <alainm@gnu.org>2001-08-01 03:26:39 +0000
committerAlain Magloire <alainm@gnu.org>2001-08-01 03:26:39 +0000
commit0ab945493744802eb818af2557386ad64039da23 (patch)
tree6bdd619ce22668b800f23815e90edc009e156256 /sieve/Makefile.am
parent0b7750b6770dd2844b335c977468dac67f1d42fb (diff)
downloadmailutils-0ab945493744802eb818af2557386ad64039da23.tar.gz
mailutils-0ab945493744802eb818af2557386ad64039da23.tar.bz2
* sieve/Makefile.am: Remove gcc specific flags.
* sieve/xmalloc.c: Removed, use lib/xmalloc.c instead. * sieve/xmalloc.h: Removed. * sieve/sysexists.h: Removed.
Diffstat (limited to 'sieve/Makefile.am')
-rw-r--r--sieve/Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/sieve/Makefile.am b/sieve/Makefile.am
index 3a186dd94..41c6e0176 100644
--- a/sieve/Makefile.am
+++ b/sieve/Makefile.am
@@ -1,4 +1,5 @@
-CFLAGS = -Wall -pedantic -g -DTESTING
+#CFLAGS = -Wall -pedantic -g -DTESTING
+AUTOMAKE_OPTIONS = ../lib/ansi2knr
INCLUDES = -I${top_srcdir}/include -I${top_srcdir}/lib
YLWRAP = $(SHELL) $(srcdir)/ylwrap
YFLAGS = -d
@@ -33,8 +34,7 @@ SRC = \
sieve_err.c \
svfield.c \
tree.c \
- util.c \
- xmalloc.c
+ util.c
HDR = \
comparator.h \
@@ -50,10 +50,8 @@ HDR = \
sieve_err.h \
sieve_interface.h \
svfield.h \
- sysexits.h \
tree.h \
- util.h \
- xmalloc.h
+ util.h
sieve_DEPENDENCIES = ../mailbox/libmailbox.la
sieve_LDADD = ../mailbox/libmailbox.la ../lib/libmailutils.a
@@ -71,11 +69,11 @@ addr.c addr.h: $(srcdir)/addr.y
-- -yy addr
sieve-lex.c: $(srcdir)/sieve-lex.l sieve-gram.h
- $(YLWRAP) "$(LEX)" $(srcdir)/sieve-lex.l lex.yy.c sieve-lex.c
+ $(YLWRAP) "$(LEX)" $(srcdir)/sieve-lex.l lex.yy.c sieve-lex.c
sieve-gram.c sieve-gram.h: $(srcdir)/sieve-gram.y
$(YLWRAP) "$(YACC) $(YFLAGS)" $(srcdir)/sieve-gram.y \
- y.tab.c sieve-gram.c y.tab.h sieve-gram.h
+ y.tab.c sieve-gram.c y.tab.h sieve-gram.h
comparator.o: sieve-gram.h
script.o: sieve-gram.h

Return to:

Send suggestions and report system problems to the System administrator.