summaryrefslogtreecommitdiff
path: root/libsieve/Makefile.am
diff options
context:
space:
mode:
authorWojciech Polak <polak@gnu.org>2009-02-13 23:25:01 +0100
committerWojciech Polak <polak@gnu.org>2009-02-13 23:25:01 +0100
commit89d404113a5e79d5a2f8215140b54897ac0b3d11 (patch)
tree0fa760dcb5f07d0ce281995b15ffbc988b2e4790 /libsieve/Makefile.am
parent8ad5ecbc640a04f0eee7f113119d3c58ed362e4c (diff)
downloadmailutils-89d404113a5e79d5a2f8215140b54897ac0b3d11.tar.gz
mailutils-89d404113a5e79d5a2f8215140b54897ac0b3d11.tar.bz2
Rename libraries.
Rename libmuauth to libmu_auth, libargp to libmu_argp, libcfg to libmu_cfg, and libsieve to libmu_sieve. * auth/*: Move to libmu_auth/* * libargp/*: Move to libmu_argp/* * libcfg/*: Move to libmu_cfg/* * libsieve/*: Move to libmu_sieve/* * libmu_sieve/sieve.h: Rename to sieve-priv.h * include/mailutils/libsieve.h: Rename to sieve.h * configure.ac: Update, bump to 2.0.90.
Diffstat (limited to 'libsieve/Makefile.am')
-rw-r--r--libsieve/Makefile.am75
1 files changed, 0 insertions, 75 deletions
diff --git a/libsieve/Makefile.am b/libsieve/Makefile.am
deleted file mode 100644
index 4023a32ac..000000000
--- a/libsieve/Makefile.am
+++ /dev/null
@@ -1,75 +0,0 @@
-## Process this file with GNU Automake to create Makefile.in
-
-## Copyright (C) 2002, 2003, 2004, 2005, 2007 Free Software Foundation, Inc.
-##
-## GNU Mailutils is free software; you can redistribute it and/or
-## modify it under the terms of the GNU General Public License as
-## published by the Free Software Foundation; either version 3, or (at
-## your option) any later version.
-##
-## This program is distributed in the hope that it will be useful, but
-## WITHOUT ANY WARRANTY; without even the implied warranty of
-## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-## General Public License for more details.
-##
-## You should have received a copy of the GNU General Public License
-## along with this program; if not, write to the Free Software
-## Foundation, Inc. 51 Franklin Street, Fifth Floor, Boston, MA
-## 02110-1301 USA
-
-INCLUDES = @MU_COMMON_INCLUDES@
-
-YLWRAP = $(SHELL) $(top_srcdir)/scripts/gylwrap
-AM_YFLAGS = -dtv
-AM_CPPFLAGS = -DSIEVE_MODDIR=\"@SIEVE_MODDIR@\"
-
-SUBDIRS = . extensions
-
-lib_LTLIBRARIES = libsieve.la
-
-libsieve_la_SOURCES = \
- actions.c\
- conf.c\
- comparator.c\
- load.c\
- prog.c\
- register.c\
- relational.c\
- require.c\
- runtime.c\
- sieve-gram.c\
- sieve-gram.h\
- sieve-lex.c\
- tests.c\
- util.c
-libsieve_la_LIBADD = ${MU_LIB_MAILUTILS} @LTDL_LIB@
-libsieve_la_LDFLAGS = -version-info @VI_CURRENT@:@VI_REVISION@:@VI_AGE@
-
-noinst_HEADERS = sieve.h
-
-BUILT_SOURCES = \
- sieve-gram.c sieve-gram.h \
- sieve-lex.c
-
-MAINTAINERCLEANFILES=$(BUILT_SOURCES)
-
-EXTRA_DIST = sieve.y sieve.l
-
-sieve-lex.c: $(srcdir)/sieve.l sieve-gram.h
- $(YLWRAP) "$(LEX) $(AM_LEXFLAGS) $(LEXFLAGS)" \
- $(srcdir)/sieve.l lex.yy.c sieve-lex.c \
- -- -yy mu_sieve_yy
-
-sieve-gram.c sieve-gram.h: $(srcdir)/sieve.y
- $(YLWRAP) "$(YACC) $(AM_YFLAGS) $(YFLAGS)" $(srcdir)/sieve.y \
- y.tab.c sieve-gram.c y.tab.h sieve-gram.h y.output y.output \
- -- -yy mu_sieve_yy
-
-
-CFLOW_FLAGS=-i^s --brief -v
-libsieve_CFLOW_INPUT=$(libsieve_la_OBJECTS:.lo=.c)
-libsieve.cflow: $(libsieve_CFLOW_INPUT) Makefile
- cflow -o$@ $(CFLOW_FLAGS) $(DEFS) \
- $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
- $(CPPFLAGS) \
- $(libsieve_CFLOW_INPUT)

Return to:

Send suggestions and report system problems to the System administrator.