summaryrefslogtreecommitdiff
path: root/libmu_scm/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2009-03-24 20:56:07 +0200
committerSergey Poznyakoff <gray@gnu.org.ua>2009-03-24 20:56:07 +0200
commit43088a1c350b70b627edeb98d927beca3bcd7708 (patch)
tree1d516191749342a1f88391f426313daf385fd8f3 /libmu_scm/Makefile.am
parent303823bda827fcf3a6f570afe4a9ad7b637663b4 (diff)
downloadmailutils-43088a1c350b70b627edeb98d927beca3bcd7708.tar.gz
mailutils-43088a1c350b70b627edeb98d927beca3bcd7708.tar.bz2
Rewrite scripting support in maidag.
* include/mailutils/guile.h (mu_guile_init, mu_guile_load) (mu_guile_eval, mu_guile_mailbox_apply, mu_guile_message_apply) (mu_guile_safe_exec, mu_guile_safe_proc_call): New protos. * libmu_scm/Makefile.am: Add mu_guile.c * libmu_scm/mu_guile.c: New file. * libmu_scm/mu_mailbox.c (struct mu_mailbox): Kludge: new member noclose. (mu_scm_mailbox_free): Do not close/destroy mailbox if it is marked noclose. (mu_scm_mailbox_create0): Kludge: new function. * libmu_scm/mu_message.c (mu_scm_message_print): Bugfix. * maidag/Makefile.am: Add guile.c and sieve.c. * maidag/deliver.c (maidag_stdio_delivery) [WITH_GUILE]: Remove block. (deliver_url): Call script_apply, instead of sieve_test. * maidag/maidag.c: Rewrite scripting support in a modular way. Remove options: --sieve, --source (and the corresponding config statements). Add options: --language, --script. Add configure statement: filter (block). * maidag/maidag.h (progfile_pattern, sieve_pattern): Remove. (script_list, sieve_debug_flags, message_id_header, sieve_enable_log): New prototypes. [WITH_GUILE]: Remove. (maidag_script_fun, struct maidag_script): New data type. (script_handler): New extern. (script_lang_handler, script_suffix_handler) (script_register, script_apply): New protos. (scheme_check_msg, sieve_check_msg): New protos. * maidag/script.c: Rewrite. Provide general-purpose serialized script support. * guimb/guimb.h (struct guimb_data): Remove. * guimb/main.c: Rewrite in a cleaner way, using functions from mu_guile.c. * guimb/collect.c (guimb_catch_body, guimb_catch_handler) (guimb_exit): Remove. * guimb/scm/sieve-core.scm (sieve-current-message, sieve-mailbox): Public. (sieve-run-current-message): New public function. (sieve-run): Call sieve-run-current-message for each message. * guimb/scm/sieve.scm.in (sieve-save-program): Change code generation to suit both per-mailbox and per-message invocation. This kicks mail.local out of whack. * maidag/guile.c: New file. * maidag/sieve.c: New file.
Diffstat (limited to 'libmu_scm/Makefile.am')
-rw-r--r--libmu_scm/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/libmu_scm/Makefile.am b/libmu_scm/Makefile.am
index 4a4ecb205..282d2621e 100644
--- a/libmu_scm/Makefile.am
+++ b/libmu_scm/Makefile.am
@@ -26,6 +26,7 @@ EXTRA_LTLIBRARIES=libmu_scm.la
C_SRCS=\
mu_address.c\
mu_body.c\
+ mu_guile.c\
mu_guimb.c\
mu_mailbox.c\
mu_message.c\

Return to:

Send suggestions and report system problems to the System administrator.