summaryrefslogtreecommitdiff
path: root/imap4d/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2010-09-12 18:44:59 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2010-09-12 18:44:59 +0300
commitfd032c6f6cf30af76f67baff997367cafdacb428 (patch)
treebf38c912cb14ddceccc5665a03fd8a7336a71d85 /imap4d/Makefile.am
parent7ebda3496ee47c3b5821375f11bd0833da2e14e4 (diff)
downloadmailutils-fd032c6f6cf30af76f67baff997367cafdacb428.tar.gz
mailutils-fd032c6f6cf30af76f67baff997367cafdacb428.tar.bz2
Mailbox quota support in imap4d: initial implementation.
* imap4d/quota.c: New file. * imap4d/Makefile.am (imap4d_SOURCES): Add quota.c * imap4d/append.c (imap4d_append0): Refuse to append if the quota is exceeded or would be exceeded after completing the operation. * imap4d/copy.c (imap4d_copy0): Refuse to copy messages if the quota is exceeded or would be exceeded after completing the operation. Return a meaningful textual description. Attempt to restore mailbox to its original size if the operation failed. * imap4d/imap4d.c (imap4d_session_setup0): Call quota_setup. * imap4d/imap4d.h (quota_setup, quota_check, quota_update): New functions. * include/mailutils/folder.h (mu_list_response) <format>: New member. * include/mailutils/mailbox.h (mu_mailbox_create_from_record): New function. * include/mailutils/types.hin (MU_FOLDER_ATTRIBUTE_LINK): New flag. * libproto/mbox/folder.c (list_helper): Do not return symbolic links unless MU_FOLDER_ATTRIBUTE_LINK is set. Fill in the resp->format member. * mailbox/mailbox.c (_mailbox_create_from_record): New static function. (_create_mailbox0): Rewrite as a wrapper over _mailbox_create_from_record. (mu_mailbox_create_from_record): New function.
Diffstat (limited to 'imap4d/Makefile.am')
-rw-r--r--imap4d/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/imap4d/Makefile.am b/imap4d/Makefile.am
index bb0c19bfb..a0bd98b7b 100644
--- a/imap4d/Makefile.am
+++ b/imap4d/Makefile.am
@@ -50,6 +50,7 @@ imap4d_SOURCES = \
noop.c\
parsebuf.c\
preauth.c\
+ quota.c\
rename.c\
search.c\
select.c\

Return to:

Send suggestions and report system problems to the System administrator.