summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlain Magloire <alainm@gnu.org>2001-08-25 15:49:53 +0000
committerAlain Magloire <alainm@gnu.org>2001-08-25 15:49:53 +0000
commitf4d3e78db91212292c8609a4eb18f6402520978a (patch)
treeef14190e81fb7d61c6151bcbadc4d45df0e82733 /configure.in
parent7ba96ca17a014cb6aa692cb03419ee324a9b8c51 (diff)
downloadmailutils-f4d3e78db91212292c8609a4eb18f6402520978a.tar.gz
mailutils-f4d3e78db91212292c8609a4eb18f6402520978a.tar.bz2
* Makefile.am:
* acconfig.h: Added support for new MySql addition to mailutils * configure.in: * MySql/Makefile.am: * MySql/MySql.c: Mini lib to link to when mysql support * MySql/MySql.h: enabled (with --enable-mysql) * doc/Readme.mysql: Readme file for setup. * imap4d/login.c: * mailbox/mbx_default.c: The Patch pretty much works the same * mailbox/mutil.c: all around. if getpwnam() returns null * mailbox2/mutil.c: then your db is checked for the user, * pop3d/apop.c: and the struct is filled if found, * pop3d/user.c: returns null if not. If shadow support is used, then the same is done with getspnam(). * examples/mail.MysqlMailer.c: Simple sendmail backend support.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 473b59521..0f2f3e3a0 100644
--- a/configure.in
+++ b/configure.in
@@ -129,6 +129,15 @@ if test x"$ac_cv_func_argp_parse" != xyes; then
AC_SUBST(ARGPINCS)
fi
+dnl check if mysql support was added
+AC_ARG_ENABLE(mysql, [ --enable-mysql enable mysql support (default no)], [use_mysql="yes"],,)
+if test x"$use_mysql" = x"yes"; then
+ echo Enabling mysql support, be sure to edit \'MySql/MySql.h\' to change default values
+ AC_CHECK_HEADER(mysql/mysql.h,
+ LIBS="$LIBS -lmailMysql -lmysqlclient -L/usr/lib/mysql -L/usr/local/lib/mysql -L../MySql/"
+ AC_DEFINE(HAVE_MYSQL))
+fi
+
dnl Use either PAM or CRYPT, not both.
if test x"$testpam" = x"yes"; then
AC_CHECK_HEADERS(security/pam_appl.h)
@@ -220,4 +229,4 @@ AC_OUTPUT(Makefile mailutils.spec include/Makefile include/mailutils/Makefile
m4/Makefile doc/Makefile argp/Makefile lib/Makefile lib/posix/Makefile
mailbox/Makefile imap4d/Makefile mailbox/include/Makefile from/Makefile
mail/Makefile pop3d/Makefile frm/Makefile sieve/Makefile messages/Makefile
- scripts/Makefile libmu_scm/Makefile guimb/Makefile guimb/scm/Makefile)
+ scripts/Makefile libmu_scm/Makefile guimb/Makefile guimb/scm/Makefile MySql/Makefile)

Return to:

Send suggestions and report system problems to the System administrator.