summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlain Magloire <alainm@gnu.org>2001-09-04 01:25:06 +0000
committerAlain Magloire <alainm@gnu.org>2001-09-04 01:25:06 +0000
commit8b262f172f15fb5afa3cb73b7c619650ee5d556f (patch)
tree11ef80382dcedfd6ef6283d8c0728eb7a06dfb43 /configure.in
parent7191f1dbdd3126049245ae0cd984fed0db7cc6a3 (diff)
downloadmailutils-8b262f172f15fb5afa3cb73b7c619650ee5d556f.tar.gz
mailutils-8b262f172f15fb5afa3cb73b7c619650ee5d556f.tar.bz2
* configure.in: AC_REPLACE_FUNCS(fgetpwent);
* include/mailutils/parse822.h: Add a prototype for parse822_skip_nl(). * lib/Makefile.am: add fgetpwent.c * lib/fgetpwent.c: New file. * mail/from.c (mail_from): Use the cover functions attribute_is_xxxx() instead of getting the flag. * mailbox/attribute.c: Cleanup the mess. attribute_set_{read,delete,seen,flagged,answered}. attribute_unset_{read,delete,seen,flagged,answered}. attribute_is_{read,delete,seen,flagged,answered} should be no more then cover functions calling attribute_set_flags(), attribute_get_flags() and attribute_unset_flags(). * mailbox/folder_imap.c: MU_ATTRIBUTE_READ, is not part of IMAP protocol use \\Seen. * mailbox/mbx_imap.c: Remove the hack trying to reconnect, it does not work. * mailbox/mbx_pop.c(pop_get_messages): Set the new functions for the attribute. (pop_get_attribute): New functions. (pop_set_attribute): New functions. (pop_unset_attribute): New functions. (pop_attr_flags): Removed. * mutil.c (mu_hex2ul): GNU coding std. (parse822_time): Do not use tzname as a variable name tzname is global variable in libc, better clear away. (parse822_date_time): Likewised. * pop3d/Makefile.am: add virtual.c * pop3d/pop3d.c (main): register getpwnam_ip_virtual, getpwnam_host_virtual * pop3d/pop3d.h: declare, getpwnam_ip_virtual(), getpwnam_host_virtual(). * pop3d/virtual.c: New file.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 9eebd5549..a26e34c0e 100644
--- a/configure.in
+++ b/configure.in
@@ -113,8 +113,8 @@ AC_FUNC_FNMATCH
if test "$ac_cv_func_fnmatch_works" = "no"; then
: LIBOBJS="$LIBOBJS fnmatch.o"
fi
-AC_REPLACE_FUNCS(setenv snprintf strtok_r strncasecmp strcasecmp strsignal \
- vasprintf)
+AC_REPLACE_FUNCS(fgetpwent setenv snprintf strtok_r strncasecmp strcasecmp \
+ strsignal vasprintf)
AC_CHECK_FUNCS(mkstemp sigaction sysconf)
dnl Check for libraries
@@ -243,7 +243,7 @@ fi
dnl Output Makefiles
AC_OUTPUT(Makefile mailutils.spec include/Makefile include/mailutils/Makefile
- m4/Makefile doc/Makefile argp/Makefile lib/Makefile lib/posix/Makefile
- mailbox/Makefile imap4d/Makefile mailbox/include/Makefile from/Makefile
+ m4/Makefile doc/Makefile argp/Makefile lib/Makefile lib/posix/Makefile
+ mailbox/Makefile imap4d/Makefile mailbox/include/Makefile from/Makefile
mail/Makefile pop3d/Makefile frm/Makefile sieve/Makefile messages/Makefile
scripts/Makefile libmu_scm/Makefile guimb/Makefile guimb/scm/Makefile MySql/Makefile)

Return to:

Send suggestions and report system problems to the System administrator.