summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlain Magloire <alainm@gnu.org>2001-10-15 05:29:37 +0000
committerAlain Magloire <alainm@gnu.org>2001-10-15 05:29:37 +0000
commit24361598116c688aeabec17db0a133af03ed0d64 (patch)
tree8fab4816d670aeba6d11f6b531752525529f053d /configure.in
parent9b87545a76b9bfa7dba19f0b7c92293c7483ec00 (diff)
downloadmailutils-24361598116c688aeabec17db0a133af03ed0d64.tar.gz
mailutils-24361598116c688aeabec17db0a133af03ed0d64.tar.bz2
The code for IMAP, is a pain, the rewrite should clean all those
hacks. Something to remember for the mailbox2 is to do some smart caching, the current buffered stream is not good enough. * configure.in: VERSION is set to 0.0.9a for the alpha. * frm/frm.c: Protype for usage(). get_personal() should use const char *. * mail/mail.c (main): Use mailbox_scan() instead of mailbox_messages_count () it is faster for IMAP. * mailbox/mbx_imap.c(imap_get_message0): Remove the stream_setbufsiz() it is no longer used. (imap_message_readline imap_body_readline): Bug fix, readline will only consume up to '\n' even though the buffer is bigger. So we have to adjust the offset/lines/size to reflect what we consume. This is not very good for example doing: { off_t offset = 14; char buffer[512]; stream_readline (stream, buffer, sizeof buffer, offset, NULL); ... } Will send to the impap server. C: g445 FETCH 4 BODY.PEEK[2]<0.2048> S: * 4 FETCH (BODY[2]<0> {739} S: g445 OK FETCH completed This is waste since the first line is only 37 bytes. We will have to come up on the second API with some smart caching. * mailbox/memory_stream.c (_memory_write): Nasty bug was not updating the stream size. * mailbox/stream.c(stream_readline): Take care of known case where the buflen is 0 or 1.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index f7a9183f8..aa801ada9 100644
--- a/configure.in
+++ b/configure.in
@@ -1,6 +1,6 @@
dnl Process this file with autoconf to procude a configure script.
AC_INIT(mailbox/mailbox.c)
-AM_INIT_AUTOMAKE(mailutils, 0.0.9)
+AM_INIT_AUTOMAKE(mailutils, 0.0.9a)
AM_CONFIG_HEADER(config.h)
dnl Check for programs
@@ -247,9 +247,9 @@ fi
dnl Output Makefiles
AC_OUTPUT(Makefile mailutils.spec include/Makefile include/mailutils/Makefile
- m4/Makefile doc/Makefile doc/rfc/Makefile doc/texinfo/Makefile argp/Makefile
- lib/Makefile lib/posix/Makefile mailbox/Makefile imap4d/Makefile
- mailbox/include/Makefile from/Makefile mail/Makefile pop3d/Makefile
- frm/Makefile sieve/Makefile messages/Makefile scripts/Makefile
+ m4/Makefile doc/Makefile doc/rfc/Makefile doc/texinfo/Makefile argp/Makefile
+ lib/Makefile lib/posix/Makefile mailbox/Makefile imap4d/Makefile
+ mailbox/include/Makefile from/Makefile mail/Makefile pop3d/Makefile
+ frm/Makefile sieve/Makefile messages/Makefile scripts/Makefile
libmu_scm/Makefile guimb/Makefile guimb/scm/Makefile
MySql/Makefile)

Return to:

Send suggestions and report system problems to the System administrator.