summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2011-11-21 14:58:23 +0200
committerSergey Poznyakoff <gray@gnu.org.ua>2011-11-21 14:58:23 +0200
commita9e36974c11d4a4c429867a63bc0814917985089 (patch)
tree6eaaa115df2ce5e6c7358e1704f9f0488ed7ebfe /configure.ac
parentd2207485610080f7f3c60b2a435c57fe5edb4ade (diff)
downloadmailutils-a9e36974c11d4a4c429867a63bc0814917985089.tar.gz
mailutils-a9e36974c11d4a4c429867a63bc0814917985089.tar.bz2
libmu_dbm: Functions for DB creation take default safety flags in their last argument.
* configure.ac (check_dbm_impl): Fix improper usage of expr in BDB=* case. * include/mailutils/dbm.h (mu_dbm_create_from_url) (mu_dbm_create): Take default safety flags as the last argument. * libmailutils/base/filesafety.c (_check_linkwrdir): Check for both hard and symbolic links. Fix the latter check. * libmailutils/tests/fsaf.at: Add check for softlink in a writable dir. * libmu_dbm/create.c (mu_dbm_create): Take default file safety as the last argument. * libmu_dbm/dbm.c (mu_dbm_create_from_url): Likewise. * maidag/mailquota.c (dbm_retrieve_quota): Update call to mu_dbm_create. Impose MU_FILE_SAFETY_ALL by default. * mu/dbm.c (open_db_file): Update call to mu_dbm_create. No checks by default. * pop3d/apop.c (pop3d_apopuser): Update call to mu_dbm_create. Use apop_database_safety as the default checks. * pop3d/bulletin.c (read_bulletin_db,write_bulletin_db): Update calls to mu_dbm_create. Use DEFAULT_GROUP_DB_SAFETY as default. * pop3d/logindelay.c (open_stat_db): Update call to mu_dbm_create. Use DEFAULT_GROUP_DB_SAFETY as default. * pop3d/pop3d.c (apop_database_safety): Initialize to MU_FILE_SAFETY_ALL. (apop_database_safety_set): Remove. * pop3d/pop3d.h (apop_database_safety_set): Remove. * pop3d/popauth.c (open_db_file): Update call to mu_dbm_create. Use safety_flags by default.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f28c42be4..4d6925462 100644
--- a/configure.ac
+++ b/configure.ac
@@ -518,7 +518,7 @@ check_dbm_impl() {
done;;
BDB=*)
- name=`expr $use_dbm : 'BDB=\(.*\)'`
+ name=`expr $1 : 'BDB=\(.*\)'`
case $name in
[[0-9]]*) check_slackware_bdb $name;;
*) for version in 4 3 2

Return to:

Send suggestions and report system problems to the System administrator.