summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2012-07-17 13:45:10 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2012-07-17 13:45:10 +0300
commit8658476839bcd6704ce51f470e14cf302b888f4a (patch)
tree0767d41002e334fc48a1cfc1acc7d1695d50fd76 /configure.ac
parent78f92501613a377b4c5bb2680dc071e928a96855 (diff)
downloadmailutils-8658476839bcd6704ce51f470e14cf302b888f4a.tar.gz
mailutils-8658476839bcd6704ce51f470e14cf302b888f4a.tar.bz2
Improve configuration options.
* am/enable.m4 (MU_ENABLE_BUILD): Change handling of additional-cond ($4): the --{enable|disable}-build-* argument value overrides it. This allows to use such configuration shortcuts as: --disable-build-clients --enable-build-mail which will build only mail, but no other client. * configure.ac: New option --with-dbm can be used to enable/disable building of all available DBM interfaces. It can be used in conjunction with implementation-specific options in the same way as described above, e.g.: --without-dbm --with-gdbm New option --with-mailbindir allows for overriding the installation directory for mail[x] only. * mail/Makefile.am (mailbindir): New variable. (bin_PROGRAMS): Rename to mailbin_PROGRAMS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 21 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index ec3b41621..1e5b6b89e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -358,8 +358,19 @@ AC_SUBST(DBMLIBS)
AC_SUBST(DBMLIB_DEPENDENCY)
AC_SUBST(DBMINCLUDES)
-enable_dbm=no
+enable_dbm=
disable_dbm=no
+all_dbm="GDBM BDB TC NDBM"
+
+AC_ARG_WITH([dbm],
+ AC_HELP_STRING([--with-dbm],
+ [build DBM support (default yes)]),
+ [
+case "${withval}" in
+ yes) enable_dbm="$all_dbm";;
+ no) enable_dbm=no;;
+ *) enable_dbm="$withval" ;;
+esac])
AC_ARG_WITH([gdbm],
AC_HELP_STRING([--with-gdbm],
@@ -570,8 +581,8 @@ check_dbm_impl() {
esac
}
-if test "$enable_dbm" = no; then
- enable_dbm="GDBM BDB TC NDBM"
+if test -z "$enable_dbm"; then
+ enable_dbm=$all_dbm
fi
for impl in $enable_dbm
@@ -1266,7 +1277,14 @@ MU_ENABLE_BUILD(comsat,,,["$mu_build_servers" = yes],,[server_list])
MU_ENABLE_BUILD(frm,,,["$mu_build_clients" = yes],,[client_list])
MU_ENABLE_BUILD(maidag,,,["$mu_build_clients" = yes],,[client_list])
+
MU_ENABLE_BUILD(mail,,,["$mu_build_clients" = yes],,[client_list])
+AC_SUBST([MAILBINDIR],'${bindir}')
+AC_ARG_WITH([mailbindir],
+ [AC_HELP_STRING([--with-mailbindir=DIR],
+ [install mail to DIR [[BINDIR]]])],
+ [MAILBINDIR=$withval])
+
MU_ENABLE_BUILD(sieve,,,["$mu_build_clients" = yes],,[client_list])
MU_ENABLE_BUILD(messages,,,["$mu_build_clients" = yes],,[client_list])
MU_ENABLE_BUILD(readmsg,,,["$mu_build_clients" = yes],,[client_list])

Return to:

Send suggestions and report system problems to the System administrator.