summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2017-03-20 20:57:26 +0200
committerSergey Poznyakoff <gray@gnu.org.ua>2017-03-20 22:28:47 +0200
commit2ca7dcd648057aaa45b6b4f74acd3afbd99e410c (patch)
tree1fdfa7472b738aca1fc9f20670ba839d85100c5c /configure.ac
parent1da223b05d0b851d6cb025af3d58f70e1c533d0a (diff)
downloadmailutils-2ca7dcd648057aaa45b6b4f74acd3afbd99e410c.tar.gz
mailutils-2ca7dcd648057aaa45b6b4f74acd3afbd99e410c.tar.bz2
Housekeeping: implement a tool for producing intermediate alpha tarballs.
Intermediate tarballs have the same version number as initial alpha version, to which is appended a suffix "-N", where N is the number of commits between the current git HEAD and the original alpha release. Additionally, the --version (or -version, for MH) output has been changed to include the N and the git description (for all releases, but stable). * .gitignore: Update. * Makefile.am: Remove git-describe and git-describe.h goals. (alpha, alphacheck): Rewrite. * configure.ac (GITINFO): New subst variable. * include/mailutils/Makefile.am (gitinfo.h): New built source. * libmailutils/cli/cli.c: Include gitinfo.h (mu_version_hook): Rewrite. * mh/mh_getopt.c: Include gitinfo.h (mh_version_hook): Rewrite. * mu-aux/gitinfo.pl: New file. * mu-aux/Makefile.am (EXTRA_DIST): Add gitinfo.pl * mu/Makefile.am (mu-setup.c): Add dependency * testsuite/testsuite.inc (MUT_VERSION): Account for changes in version output.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fb3322f6d..938269b47 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1370,6 +1370,12 @@ CPPFLAGS="$CPPFLAGS -DSYSCONFDIR=\\\"\$(sysconfdir)\\\""
# Doc hints.
IMPRIMATUR_INIT([doc/imprimatur])
+AC_PATH_PROG([PERL], perl)
+if test -z "$PERL"; then
+ PERL=false
+fi
+AC_SUBST([GITINFO],'$(PERL) $(mu_aux_dir)/gitinfo.pl')
+
AC_CONFIG_COMMANDS([status],[
cat <<EOF

Return to:

Send suggestions and report system problems to the System administrator.