aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am37
1 files changed, 35 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 72619ec..0eb4b0e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,39 @@
1SUBDIRS=src @GRECS_TESTDIR@ @GRECS_DOCDIR@ 1# This file is part of Grecs
2EXTRA_DIST=@GRECS_BUILD_AUX@ 2# Copyright (C) 2007, 2009-2011 Sergey Poznyakoff
3#
4# Grecs is free software; you can redistribute it and/or modify
5# it under the terms of the GNU General Public License as published by
6# the Free Software Foundation; either version 3, or (at your option)
7# any later version.
8#
9# Grecs is distributed in the hope that it will be useful,
10# but WITHOUT ANY WARRANTY; without even the implied warranty of
11# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
12# GNU General Public License for more details.
13#
14# You should have received a copy of the GNU General Public License
15# along with Grecs. If not, see <http://www.gnu.org/licenses/>.
16
3ACLOCAL_AMFLAGS = -I am 17ACLOCAL_AMFLAGS = -I am
18SUBDIRS=. src @GRECS_TESTDIR@ @GRECS_DOCDIR@
19EXTRA_DIST=@GRECS_BUILD_AUX@ gitid.h
20
21noinst_HEADERS = gitid.h
22BUILT_SOURCES = gitid.h
23
24.PHONY: gitid.h
25gitid.h:
26 @if test -d .git; then \
27 url=`git config --get remote.origin.url | sed 's|.*://||'`; \
28 if test "$$url" = "git.gnu.org.ua/gitroot/grecs.git"; then \
29 dirty=`git diff-index --name-only HEAD 2>/dev/null` || dirty=;\
30 test -n "$$dirty" && dirty="-dirty"; \
31 ID=`git log -1 --pretty='%H-%ct-%ae'`$$dirty;\
32 echo "#define GRECS_GIT_ID \"$$ID\"" > gitid.tmp; \
33 cmp gitid.tmp gitid.h >/dev/null 2>&1 || mv gitid.tmp gitid.h; \
34 rm -f gitid.tmp; \
35 fi; \
36 fi;
4 37
5@GRECS_CHANGELOG@.PHONY: ChangeLog 38@GRECS_CHANGELOG@.PHONY: ChangeLog
6@GRECS_CHANGELOG@ChangeLog: 39@GRECS_CHANGELOG@ChangeLog:

Return to:

Send suggestions and report system problems to the System administrator.