aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2009-02-16 01:30:44 +0200
committerSergey Poznyakoff <gray@gnu.org.ua>2009-02-16 01:37:24 +0200
commit4ea235014b22e357c7a6e283ce52b80a1778c0bd (patch)
tree7b79814ed11bcb02d08a13d92138ea9215778723 /Makefile.am
downloadgrecs-4ea235014b22e357c7a6e283ce52b80a1778c0bd.tar.gz
grecs-4ea235014b22e357c7a6e283ce52b80a1778c0bd.tar.bz2
Rewrite configuration parser, drop dependency on GSC
* bootstrap: Replaced with a modified version from gnulib. * configure.ac: Bump version to 1.9.90 (--without-preprocessor): New option Require Mailutils 2.0 (AC_CONFIG_FILES): Remove lib, add gconf * gconf/: New directory. Contains general-purpose configuration file parser, distilled from Dico and Mailutils. * src/Makefile.am (wydawca_SOURCES): Add interval.c * src/pp-setup, src/update-2.0.awk: New files. * src/config.c: Full rewrite. * src/exec.c (start_prog): Use getdtablesize unconditionally. * src/mail.c: Keep templates in a hash table. Template references begin with a single @ * src/process.c, src/triplet.c, src/verify.c: Reflect changes to struct directory_pair * src/wydawca.c: Change configuration parsing. * src/wydawca.h (enum access_method_id): New constants (struct directory_pair): Replace four access methods with an array. * Makefile.am (SUBDIRS): Remove lib, add gconf * .gitignore, NEWS, doc/.gitignore, src/.gitignore
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..4f50bd6
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,17 @@
+noinst_LIBRARIES=libgconf.a
+libgconf_a_SOURCES = \
+ argcv.c\
+ argcv.h\
+ gconf-format.c\
+ gconf-gram.y\
+ gconf-lex.l\
+ gconf-preproc.c\
+ gconf-text.c\
+ gconf.h
+
+EXTRA_DIST=gconf-gram.h
+
+INCLUDES = -I$(top_srcdir)/gnu -I../gnu
+AM_YFLAGS = -dtv
+AM_LFLAGS = -dvp
+

Return to:

Send suggestions and report system problems to the System administrator.