aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..a7c97e1
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,22 @@
+ACLOCAL_AMFLAGS = -I m4
+SUBDIRS = gdbm/master gdbm/newcache src
+BENCHMARKDIR=benchmarks
+benchmark:
+ @if test -z "$(NRECS)"; then \
+ echo "Please set NRECS"; \
+ exit 1; \
+ fi; \
+ if test -z "$(NKEYS)"; then \
+ echo "Please set NKEYS"; \
+ exit 1; \
+ fi; \
+ DIRNAME="$(BENCHMARKDIR)/$(NRECS)-$(NKEYS)"; \
+ if ! test -d "$$DIRNAME"; then \
+ mkdir -p $$DIRNAME; \
+ (echo "NRECS=$(NRECS)"; \
+ echo "NKEYS=$(NKEYS)"; \
+ echo "MAXCACHE=$(MAXCACHE)"; \
+ echo "include @abs_top_builddir@/src/benchmark.mk") > $$DIRNAME/Makefile; \
+ fi; \
+ $(MAKE) -C $$DIRNAME
+

Return to:

Send suggestions and report system problems to the System administrator.