aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 22 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 25c4ff4..eff0083 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,20 +39,36 @@ AC_SUBST([GDBM_VERSION_PATCH], m4_ifdef([_GDBM_VERSION_PATCH],_GDBM_VERSION_PATC
AC_ARG_ENABLE([memory-mapped-io],
AC_HELP_STRING(
- [--enable-memory-mapped-io]
+ [--enable-memory-mapped-io],
[Use mmap(2) for disk I/O. (Default is YES.)]),
- [mapped_io=$enableval],
- [mapped_io=yes])
+ [mapped_io=$enableval],
+ [mapped_io=yes])
AC_ARG_ENABLE([libgdbm-compat],
AC_HELP_STRING(
- [--enable-libgdbm-compat]
+ [--enable-libgdbm-compat],
[Build and install libgdbm_compat. (Default is NO.)]),
- [want_compat=$enableval],
- [want_compat=no])
+ [want_compat=$enableval],
+ [want_compat=no])
AC_ARG_VAR([COMPATINCLUDEDIR],[installation directory for dbm.h and ndbm.h])
test -z "$COMPATINCLUDEDIR" && COMPATINCLUDEDIR='$(includedir)'
+AC_ARG_ENABLE([gdbmtool-debug],
+ AC_HELP_STRING(
+ [--enable-gdbmtool-debug],
+ [instrument gdbmtool for additional debugging]),
+ [want_gdbmtool_debug=$enableval],
+ [want_gdbmtool_debug=no])
+
+AC_SUBST(YFLAGS_DEBUG)
+AC_SUBST(LFLAGS_DEBUG)
+if test "$want_gdbmtool_debug" = yes; then
+ YFLAGS_DEBUG=-t
+ LFLAGS_DEBUG=-d
+fi
+
+AM_CONDITIONAL([COND_GDBMTOOL_DEBUG], [test "$want_gdbmtool_debug" = yes])
+
dnl Check for programs
AC_PROG_CC
AC_PROG_CPP

Return to:

Send suggestions and report system problems to the System administrator.