aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 7 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index a79c974..3cb4b62 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
# This file is part of GDBM. -*- autoconf -*-
-# Copyright (C) 2007-2021 Free Software Foundation, Inc.
+# Copyright (C) 2007-2023 Free Software Foundation, Inc.
#
# GDBM is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -15,7 +15,8 @@
# along with GDBM. If not, see <http://www.gnu.org/licenses/>. */
m4_define([_GDBM_VERSION_MAJOR], 1)
-m4_define([_GDBM_VERSION_MINOR], 22)
+m4_define([_GDBM_VERSION_MINOR], 23)
+m4_define([_GDBM_VERSION_PATCH], 90)
AC_INIT([gdbm],
_GDBM_VERSION_MAJOR._GDBM_VERSION_MINOR[]m4_ifdef([_GDBM_VERSION_PATCH],._GDBM_VERSION_PATCH),
@@ -121,7 +122,7 @@ AM_GNU_GETTEXT_VERSION
AC_CHECK_HEADERS([sys/file.h string.h locale.h getopt.h])
-AC_CHECK_FUNCS([ftruncate flock lockf fsync setlocale getopt_long])
+AC_CHECK_FUNCS([ftruncate flock lockf fsync setlocale getopt_long getline])
if test x$mapped_io = xyes
then
@@ -227,12 +228,6 @@ AM_CONDITIONAL([GDBM_COND_DEBUG_ENABLE], [test "$status_debug" = "yes"])
AC_SUBST(YFLAGS_DEBUG)
AC_SUBST(LFLAGS_DEBUG)
if test "$want_gdbmtool_debug" = yes; then
- if ! $LEX --version 2>/dev/null | grep -q flex; then
- AC_MSG_ERROR([--enable-gdbmtool-debug requires flex, which is not available])
- fi
- if ! $YACC --version 2>/dev/null | grep -q bison; then
- AC_MSG_ERROR([--enable-gdbmtool-debug requires bison, which is not available])
- fi
YFLAGS_DEBUG=-t
LFLAGS_DEBUG=-d
fi
@@ -262,10 +257,11 @@ EOF
if test "$want_gdbmtool_debug" != default; then
cat <<EOF
NOTE: You used the --enable-gdbmtool-debug option. In order for your changes
-NOTE: to take effect, please run the following command prior to building the
+NOTE: to take effect, please run the following commands prior to building the
NOTE: package:
NOTE:
NOTE: make -C src maintainer-clean-generic
+NOTE: make -C tools maintainer-clean-generic
NOTE:
EOF
fi
@@ -280,6 +276,7 @@ status_ficlone=$status_ficlone])
AC_CONFIG_FILES([Makefile
src/Makefile
src/gdbm.h
+ tools/Makefile
doc/Makefile
compat/Makefile])

Return to:

Send suggestions and report system problems to the System administrator.