aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2021-11-18 15:46:34 +0200
committerSergey Poznyakoff <gray@gnu.org>2021-11-20 08:59:03 +0200
commitd38991be3ee99b158e889e78439fc21723154767 (patch)
tree54bf2d7f4e938d3a5ca1b90782a9cfbe626438cb /src/Makefile.am
parent669d541702fa39cd45ceab1eb333cb100c0d08ac (diff)
downloadgdbm-d38991be3ee99b158e889e78439fc21723154767.tar.gz
gdbm-d38991be3ee99b158e889e78439fc21723154767.tar.bz2
Rearrange the directory structure
Sources for the libgdbm library reside in src/. Sources for building accompanying tools are moved to the tools/ subdirectory.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am61
1 files changed, 2 insertions, 59 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 316bfcc..c088cce 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -14,24 +14,17 @@
# You should have received a copy of the GNU General Public License
# along with GDBM. If not, see <http://www.gnu.org/licenses/>.
-# Flags
-AM_CPPFLAGS=-DIN_GDBM -DLOCALEDIR=\"$(localedir)\"
-
# Headers
nodist_include_HEADERS = gdbm.h
noinst_HEADERS = \
gdbmconst.h\
gdbmdefs.h\
gettext.h\
- gram.h\
proto.h\
systems.h
-EXTRA_DIST = gdbm.h.in gdbm.magic gram.y lex.l
-BUILT_SOURCES = gdbm.h gram.h gram.c lex.c
-
-gram.c gram.h: gram.y
-lex.c: lex.l
+EXTRA_DIST = gdbm.h.in gdbm.magic
+BUILT_SOURCES = gdbm.h
# The libraries
VI_CURRENT = 6
@@ -78,53 +71,3 @@ endif
libgdbm_la_LDFLAGS = -version-info $(VI_CURRENT):$(VI_REVISION):$(VI_AGE)
-noinst_LIBRARIES = libgdbmapp.a
-
-libgdbmapp_a_SOURCES =\
- err.c\
- mem.c\
- gdbmapp.h\
- parseopt.c\
- progname.c\
- datconv.c\
- gram.c\
- input-argv.c\
- input-file.c\
- input-null.c\
- input-std.c\
- lex.c\
- gdbmshell.c\
- var.c\
- util.c\
- wordwrap.c
-
-if GDBM_COND_READLINE
- libgdbmapp_a_SOURCES += input-rl.c
-endif
-
-# Programs
-bin_PROGRAMS = gdbmtool gdbm_load gdbm_dump
-
-gdbmtool_LDADD = \
- ./libgdbmapp.a\
- ./libgdbm.la\
- @READLINE_LIBS@
-
-gdbmtool_SOURCES = \
- gdbmtool.h\
- gdbmtool.c
-
-AM_YFLAGS = -dv $(YFLAGS_DEBUG)
-AM_LFLAGS = $(LFLAGS_DEBUG)
-
-.l.c:
- $(AM_V_GEN)$(FLEX) -o $@ $(AM_LFLAGS) $<
-.y.c:
- $(AM_V_GEN)$(BISON) -o $@ $(AM_YFLAGS) $<
-
-if COND_GDBMTOOL_DEBUG
- AM_CPPFLAGS += -DGDBMTOOL_DEBUG=1
-endif
-
-gdbm_load_LDADD = ./libgdbmapp.a ./libgdbm.la
-gdbm_dump_LDADD = ./libgdbmapp.a ./libgdbm.la

Return to:

Send suggestions and report system problems to the System administrator.