aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2021-08-13 12:50:59 +0300
committerSergey Poznyakoff <gray@gnu.org>2021-08-13 13:12:24 +0300
commit343421b76722f77b8ac456b22985ad1e8af4d412 (patch)
tree26634f0ba2e24f8c729e188721c1094e0724fd2c /src/Makefile.am
parent2646db9927829881631739748233085fc3427bad (diff)
downloadgdbm-343421b76722f77b8ac456b22985ad1e8af4d412.tar.gz
gdbm-343421b76722f77b8ac456b22985ad1e8af4d412.tar.bz2
gdbmtool: always provide stdin stream
* src/Makefile.am (libgdbmapp_a_SOURCES): Add input-std.c * src/gdbmshell.c (input_history_begin): Improve diagnostic message. * src/gdbmtool.c (instream_default_create): New define. (gdbmtool_init): Use instream_default_create. * src/gdbmtool.h [WITH_READLINE] (instream_readline_create_: New proto. (input_stream_name): New proto. * src/input-rl.c (instream_stdin_create): Rename to instream_readline_create. Fall back to instream_stdin_create if stdin is not connected to a tty. * src/lex.l (input_stream_name): New function.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d4d53c6..812d6d3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -91,6 +91,7 @@ libgdbmapp_a_SOURCES =\
input-argv.c\
input-file.c\
input-null.c\
+ input-std.c\
lex.l\
gdbmshell.c\
var.c\
@@ -98,8 +99,6 @@ libgdbmapp_a_SOURCES =\
if GDBM_COND_READLINE
libgdbmapp_a_SOURCES += input-rl.c
-else
- libgdbmapp_a_SOURCES += input-std.c
endif
# Programs

Return to:

Send suggestions and report system problems to the System administrator.